50-prompt does not select git prompt in tmux

When I shell into my CL machines I get this nice git prompt indicating which branch I’m in. I did not realize how dependent on that feature I would become. Recently I changed my workflow to include tmux. Unfortunately when tmux is running I do not get the _git_dir. Looking closely at the /usr/share/defaults/etc/profile.d/50-prompt.sh there is a line of code:

if [ "${TERM:0:5}" = "xterm" ]; then

This suggests that the code is looking for something like xterm but it seems that by detault the tmux sets the TERM variable to screen.

I managed to work around this by setting TERM="" in my .bashrc but it would be better for compatibility reasons if a developer would fix that.