Audacity flatpak fails to install from software app

Using ClearLinux software app, attempting to install Audacity produces error Unable to load summary from remote Flatpak: Error resolving""

Research elsewhere returns clock discrepancy or faulty connection as possible culprits, but neither appears likely in this case. Clean install and extremely strong wireless.

Any suggestions?

Hey @phalange welcome! I noticed your post got buried a bit. Are you continuing to have this problem or was it a temporary network issue?

The problem was persistent over about a week. I finally abandoned using the ClearLinux store and simply installed Audacity the usual way via Flatpak CLI. This resulted in a complete and fully functional installation as expected.

I can’t say this issue is solved since there may be an issue with the ClearLinux store or something else. I am test driving ClearLinux, so my goal was to test the store app. Flatpak itself appears to be functioning normally independent of the store.

I’m glad to hear you have the workaround. There have been reports here and on GitHub about issues with FlatPak installation status using the GNOME software center but I haven’t seen the message you shared before.

If you have any more details, please feel free to share them in the GitHub issue:

Ok, I’ll follow up on GH

@puneetse It still doesn’t work with the ClearLinux store and while using Flatpak CLI I got a warning but the app works fine
Warning: Failed to get revokefs-fuse socket from system-helper: User flatpak does not exist in password file entry

I’ve also found that the GUI software installer usually fails to work, and usually resort to the Flatpak CLI installer. I actually prefer the CLI installer because it shows me the support libraries it is installing for a given app, and the download progress for those libraries. The GUI installer does not show download progress.