Bootable USB not showing up in Boot Sequence

Hello,

I’ve tried to install Clear Linux on a number of occasions, but for whatever reason, my bootable USB isn’t showing up. I’ve followed the documented guide step by step and I’ve tried doing certain things my own way. I managed to get it to boot once, but then my laptop crashed and it made me a very sad penguin.

I’ve tried booting on 3 different laptops, we have an XPS 13 (9370), XPS 15 (9570), and a Precision 5530 2-in-1. In case anyone needs to know the hardware.

I’d really appreciate if someone would be able to help me out! ^^

Please disable the RAID from your hard drive, and try again.
This is found in the platform BIOS settings.

Unfortunately, it didn’t fix anything.

Have you checked that UEFI boot is enabled in the bios? There are unfortunately many issues that can influence booting of USB sticks, for instance “quick boot” options might influence it, and so do RAID options. Sometimes trying a different branch USB stick may also help.

My BIOS is set to only boot in UEFI, Fastboot is set to thorough, and RAID is set to AHCI. But, what do you mean by a different USB branch?

Not branch, “USB memory stick”. :slight_smile:

In UEFI or BIOS, most systems have a “boot order” menu, where the user can tell the system which storage device to scan first for a boot loader. It is usually necessary to explicitly change the boot order to make the system look to the removable media first. (Most systems attempt to boot from fixed media first to avoid the possibility of a malware infection. Some systems even reset the boot order so that the next manual reboot returns to checking the fixed media first.)

It is usually best to plug in your USB stick before you power up your system. Then, when you enter your BIOS or UEFI menu, detected bootable devices should be displayed in the “boot order” menu. Set your USB stick as first, save your changes, and exit the menu. This is how my systems have worked, at any rate; YMMV.

I’ve tried everything that you’ve explained there, but the USB won’t show up in the boot order. I’m going to try the install with different USBs like ahkok mentioned, to see if that might have anything to do with it.

Edit: Using different USB sticks didn’t make a difference. :frowning:

It’s really fishing in the dark here - your problem could be anything.

Did you perhaps dd ... of=/dev/sdb1 instead of dd ... of=/dev/sdb or something like that? (note the 1)

I was mainly hoping someone might point something out that I hadn’t tried. I didn’t accidentally do sdx1.

Try going into the “Boot menu” (commonly F12 or F8, sometimes other keys) and enumerating the boot options you see displayed. Even an “EFI Shell” may be of help because it allows you to manually boot an UEFI OS.

You did uncompress the .xz image, right? :slight_smile:

Forgetting to uncompress the xz image caught me out the other day. The other issue I ran into was that I had to turn off secure boot to get my USB drive to show as an option.

Oh no… I can’t believe I didn’t think about that! I’ve never come across a .xz file before, and it doesn’t say to do it in the documentation. I feel like an idiot now. xD

How would I go about doing that?

=)

unxz $imagefile.img.xz should do the trick.

Which documentation are you looking at? If it’s missing somewhere, we can fix that, but I do see it spelled out in https://clearlinux.org/documentation/clear-linux/get-started/bootable-usb/bootable-usb-linux

I was looking at a different page. I apologise, I must have missed it.