Chromebook Pixel 2015 (Samus) sound

Try 5-th bullet point in this post:

Thanks for your response!
Out of some reason, I got stuck at the beginning of the instructions. After typing cd ./sound the result is: bash: cd: ./sound: No such file or directory

You need to download the stuff listed in previous steps…

I see - thanks for your advice - but as far as I know, I am not able to install deb files, when using clearlinux - or am I wrong?

You can manually install its contents.

Read the updated guide here

Thanks - unfortunatelly I got stuck here:

$ make nconfig
HOSTCC scripts/basic/fixdep
HOSTCC scripts/kconfig/nconf.o
In file included from scripts/kconfig/nconf.c:15:
scripts/kconfig/nconf.h:18:10: fatal error: curses.h: No such file or directory
18 | #include <curses.h>
| ^~~~~~~~~~
compilation terminated.
make[1]: *** [scripts/ scripts/kconfig/nconf.o] Error 1
make: *** [Makefile:515: nconfig] Error 2

sudo swupd search-file /usr/include/curses.h results show you can add the devpkg-ncurses bundle for that include.

Thanks - that helped - sorry that I have to inform you that the next command brought up the following result:
$ make -j4
Makefile:975: *** “Cannot generate ORC metadata for CONFIG_UNWINDER_ORC=y, please install libelf-dev, libelf-devel or elfutils-libelf-devel”. Stop.
The swupd search command did not bring up any reasonable result concerning the highlighted programms

As long as you know the package name, you can try to build it from the source.

I know - unfortunatelly this exceeds my abilities - I am more an interested user than someone with a professional background. I would understand, if you would tell me, that in this case, I should turn to less complex installation projects :wink:

You don’t have to be professional to build a package.
Most of times building is just configure + make + make install

Thanks - I will try my best :wink:

After some trials, I have to admit that I was not able to build the relevant package. I found this instruction and some others. I even was able to run the configure command - but make and make install only caused the result: No targets specified and no makefile found. I think, that these are child problems for you guys, but I am stuck. But, as I said - maybe its better for people of my knowledge level to try easier tasks, than to install a OS on a device that needs costumization…

Did you CD into libelf directory after ./configure and before make?

Yes - I did - same result…

Get the source code from its repository;a=summary

Then the README file tells you what to do.

Thanks again - I know github, but I never tried to get some source code from a repository.
Problem 1: Where to download the source code (do not see an appropriate link)
Problem 2: Since I don’t know what to download, I do not see any chance to to track the relevant Readme file.

git clone

Sorry to come back to you again - I had a look at this new link but it did not solve my questions above :frowning:

Run git clone