ClearLinux Boot Logs - Login Issue

I’m having problems booting/logging into ClearLinux so I’m trying to find the relevant logs to help solve the issue. I would appreciate some help finding with which log files to look at to help solve this, or if anyone has any ideas what the problem might be I would appreciate any suggestions.


When the login screen appears my user icon is not there, and when I try to login my credentials work but it just restarts the login screen and brings me back to the user selection screen to login again. If I enter invalid credentials it won’t let me login because the credentials are invalid and does not restart the login screen. I had issues in the past where customizations made to the ~/.profile ~/.bashrc and some bash aliases caused issues logging in, so I removed those files and tried to boot again but still could not login.


I see in /var/log there are a few files, but I don’t see anything that’s been helpful. I have a second installation of ClearLinux on a separate drive that I am using (I keep it for troubleshooting issues like this) but I do need to get the other installation working as I have spent a lot of time setting it up and it has some projects that I have put a lot of time into (things that can’t easily be transferred, they have to be installed and configured).

I have recently removed an external hard drive bay because a drive died, so I can’t just plug it back in to see if that would make it boot. I’m thinking there could be a file the computer is trying to read on the external bay that can’t; I have read other people who have had issues logging in have had missing files that caused the issue.

Recent Changes:

I have docker on the ClearLinux installation with some compose projects that I’ve been working on lately. I also had recently setup NFS and tried setting up Samba (but that didn’t work, I’m not sure if that’s still trying to start and failing, but I can’t find where that would be).

I used find to make a log of files that were modified in the last 10 days, but it’s fairly large and I can’t see anything that stands out. If someone could recommend some log files to look at, or some files to check that may be causing the issue, I would be very much appreciate it. Most of the changed files seem to be docker or system updates (I can’t tell which version I’m using because I can’t login).


I’m not sure if this is relevant but the /var/log/samba/log.samba file has the following error:

exit_daemon: daemon failed to start: Samba detected misconfigured 'server role' and exited. Check logs for details, error code 22


Here are the /var/log files:

-rw-rw----  1 root          utmp              3072 Feb  7 19:48 btmp
-rw-r--r--  1 root          root               219 Jan 17 19:21 dnf.librepo.log
-rw-r--r--  1 root          root              1654 Jan 17 19:21 dnf.log
-rw-r--r--  1 root          root                54 Jan 17 19:21 dnf.rpm.log
drwxr-xr-x  2 elasticsearch elasticsearch     4096 Jan 16 21:06 elasticsearch
drwx--x--x  2 root          gdm               4096 Jan 16 11:47 gdm
drwxr-xr-x  2 root          root              4096 Jan 16 18:03 httpd
drwxr-sr-x+ 3 root          systemd-journal   4096 Jan 16 11:47 journal
-rw-rw-r--  1 root          utmp            292584 Feb  6 20:20 lastlog
drwx------  2 root          root              4096 Mar 22 14:25 letsencrypt
drwxr-x---  2 httpd         httpd             4096 Mar  9 14:33 nginx
drwxr-x---  2 httpd         httpd             4096 Jan 16 18:03 nginx-mainline
drwx------  2 root          root              4096 Jan 15 21:43 private
drwx------  3 root          root              4096 Mar 24 09:42 samba
-rw-rw-r--  1 root          utmp             90624 Apr  1 09:16 wtmp
-rw-r--r--  1 root          andrew           31356 Apr  1 09:16 Xorg.0.log
-rw-r--r--  1 root          andrew           31356 Apr  1 09:16 Xorg.0.log.old

There is nothing in the gdm folder or private folder.

More Information

I made a couple gists if anyone thinks these might be helpful:

Thanks in advance

Can you login through another tty? (e.g `CTRL + ALT + F4)

This sticks out from your Xorg log
[ 30.591] (EE) systemd-logind: failed to get session: PID 3623 does not belong to any known session

If you can, take a look at the status of the systemd-logind service before and after your login attempt:
systemctl status systemd-logind.service

Otherwise take a look at the journal with journalctl -D.

1 Like

If you don’t find any breadcrumbs, you can try a repair:

The swupd repair command in that document probably needs updating to include --statedir=/mnt/var/lib/swupd nowadays.

Keep in mind that will replace and remove files under /usr. (not /usr/local though)

1 Like

Thanks @puneetse, I very much appreciate your quick responses. I took some time to try your suggestions but I still can’t log in.

I have tried the ctrl+alt+f4 at the login screen, it prompts me to login (saying <computer name> login:) but when I enter my username it says permission denied, and that’s the only user account I can log into. I can’t run systemctl since I can’t login; I can get no further in the terminal than the login prompt.
It seems that everything is fine until I try to login into the main user account, I was wondering if there would be a way to add a new administrator user account, maybe that would enable me to log in? I am guessing that something within my home directory is causing the issue since the OS is fine up until that point, but I am not sure.

I also tried the swupd repair with the --statedir however nothing was fixed. I didn’t use the --picky option because I have some manually installed manually that I was worried might be effected.

I would be very thankful for any thoughts, suggestions, or advice.
Thanks again

From a live image you can mount the rootfs of the Clear Linux that won’t let you login and run useradd with the --root parameter: sudo useradd --root=/mnt -G wheel puneetse

Or manually edit the /etc/passwd and /etc/group files under the mounted rootfs.

But if systemd-logind is actually failing like the log suggested, it still might not let you login. In which case you can try appending to your kernel boot parameters (hold SPACE during boot up to interrupt the bootloader and push e to edit the cmdline).

1 Like

I added a user, I had to use chroot with the useradd, the useradd with --root did not seem to work. Once I added a user I couldn’t set a password with passwd, just said:

passwd: Permission denied
passwd: password unchanged

I can’t seem to get to the kernal boot parameters by holding space while booting. Any other ideas or suggestions?