Getting Subversion not to ask for my password

Before switching CLR, the Linux distros I used has a version of Subversion that was able to use a keyring out of the box. With CLR, I can’t get CLR/Gnome 3/Seahorse to store non-plain passwords (and I can’t switch to other VCSs).

In ~/.subversion/config I have:

password-stores = gnome-keyring

and in ~/.subversion/servers:

[global]
store-passwords = yes
store-plaintext-passwords = no

but every svn command asks me for my password. I tried other options (e.g. password-stores = gpg-agent) to no avail.

Anyone knows how to solve this?

subversion currently isn’t built with Gnome-keyring support (or kwallet), see https://github.com/clearlinux-pkgs/subversion/blob/master/configure_misses#L13 You’ll need to make a bug so that it can be added to the build in a future release.

Bug tracker is here https://github.com/clearlinux/distribution/issues

Just posting here that I’m rebuilding subversion with gnome-keyring support, likely will show up early next week.

3 Likes

Ah cool, that will be a relief :slight_smile: Thank you