GUI packages X11 missing?

I start a portable software via terminal script. Now I tried to arrange this through the support so that I could start the software via an icon or similar.
I got the suggestion to make an add-on according to: from (without) ./software --no-sandbox, to (with) ./software --no-sandbox -extension GLX
It didn’t work, so the next suggestion was, / Full path / software --no-sandbox -extension GLX
It didn’t work either, so the next suggestion was as follows: Try installing all the GUI packages like X11, when support thought this was missing in Clear Linux.

Origin script

cd ~ / Downloads

unzip software_Portable_Linux-x64.zip

cd software \ Portable /

chmod + x ./software --no-sandbox

So it works to open the portable software. But the purpose was to arrange an icon or similar to start it in a simpler way. Now the support did not mention what would be achieved with this, (and I did not ask for it), but maybe an opportunity would be created to add it to favorites?

So is it that subcommand? that is missing in ClearLinux OS, “extension (GLX)”?
So if, do I need to install GUI packages? (and if so, how?)
Should I do, or avoid it?
How do I solve this?

I first got the following error message as well: Fontconfig error: Cannot load default config file
[4708: 0304 / 144736.546858: ERROR: buffer_manager.cc (488)] [.DisplayCompositor] GL ERROR: GL_INVALID_OPERATION: glBufferData "

The support’s response to this was as follows:
Seems to be a hardware acceleration error, try this:

Which I haven’t looked at yet. Which is certainly not something I either understand or work out?

I think you’re missing something. Did you install the desktop bundle? Did you start a desktop environment?

It’s entirely unclear what bundles you have installed, whether X is already running or not, from your message. What happens when you type xterm ? Does it start the X terminal or tell you to install something with swupd? Or some error?

Having an X11 application requires that the X11 server is running as well as (obviously) installed. It is part of the x11-server bundle, but you don’t just want that - you want e.g. the desktop bundle.

Also, it would really help if you could post what software you’re trying to run. Even if it is proprietary, we may be able to help better if we knew what it was.

You are absolutely right that I probably missed something. I lack both knowledge and experience of the Linux environment as I am a beginner (since a week or two). My intention was to try to simplify the case, but it apparently had the opposite effect. Sorry about that!
Hope the following is clearer.

I use a laptop, thus a desktop environment, where I downloaded a folder with a portable version of software to manage files from a cloud service. In this case, Icedrive.
Icedrive writes the following on its website about the software: "Full-Featured Portable App
Take Icedrive with you wherever you go - On any operating system!
No feature has been overlooked - Easily upload and download files and folders, stream your media with a built in media player, preview all popular document formats and view your images without having to download. "

I start the portable software via the following script.

cd ~ / Downloads

cd Icedrive \ Portable /

chmod + x ./Icedrive

./Icedrive --no-sandbox

The original script also contains the following line (line 2). Which extracts the files from a zip file.

“unzip Icedrive_Portable_Linux-x64.zip”

The software starts up and works but with the following terminal errors.

Fontconfig error: Cannot load default config file
[3749: 0305 / 094834.260100: ERROR: buffer_manager.cc (488)] [.DisplayCompositor] GL ERROR: GL_INVALID_OPERATION: glBufferData: <- error from previous GL command
[3749: 0305 / 094834.518563: ERROR: buffer_manager.cc (488)] [.DisplayCompositor] GL ERROR: GL_INVALID_OPERATION: glBufferData: <- error from previous GL command


The support’s response to that error message was as follows.
"Seems to be a hardware acceleration error, try this:

https://unix.stackexchange.com/questions/408582/how-to-disable-hardware-acceleration-in-linux "

Which I have not yet looked at, as I was focused on trying to find a solution for the startup in a smoother way e.g. via an icon or similar.



(Irrelevant in the case but as an example of a better solution, which I also use is Tresorit which installs a virtual hard drive on the laptop, which is so much easier to use.)


I got support from the support step by step to test according to what I was trying to describe with my post.

Namely as below

step 1 (original line to change with add-on)

./Icedrive --no-sandbox

step 2 (supplement with “extension GLX”)

./Icedrive --no-sandbox -extension GLX

step 3 (addition of “full path” together with “extension GLX”)

/ Full path / Icedrive --no-sandbox -extension GLX

Step 4 (a new proposal for a solution as none of the above worked, assuming that Clear Linux was missing the usual packages)

Try installing all the GUI packages like X11

There I definitely latched on to the latter package proposal. Then I do not know how it would go, or if it is even possible or appropriate to try it.

If it works, do you really care?

This is likely a vendor software problem. ClearLinux OS has all the bits needed to support this application as far as I can see. I can run it myself, although I don’t have a login on Icedrive, but it starts fine (with the same errors).

Now I think you misunderstood my case, or I’m unclear.

I tried to get help running the program via an icon or similar. Some AppImage programs which do not have the opportunity to add them to favorites, them I have been able to put to the desktop at least, to be able to start them from there, but not this one, without starting via the terminal. Suppose you can create a batch file (is it called that?) Which can launch programs at startup. I will look for this solution later.

Thanks anyway

A .desktop file might be what you’re looking for.

https://developer.gnome.org/integration-guide/stable/desktop-files.html.en
https://specifications.freedesktop.org/desktop-entry-spec/latest/apa.html

https://community.clearlinux.org/t/how-to-create-custom-launcher-in-gnome-desktop/

Thanks for the links. Have now created an executable desktop file according to your links, and the one below to technastic.com It works now, except the missing icon, only text is displayed.
Has scaled the icon image size to 52x52 points. May try to look more closely at why the icon does not appear.
Added the executable desktop file under: usr/share/applications
The executable desktop file looks like this:

[Desktop Entry]
The encoding = UTF-8
Version = 1.0
Type = application
Terminal = false
Exec = /home/StefanH/Downloads/Icedrive\ Portable/Icedrive
Name = Icedrive
Icon = /home/StefanH/Downloads/Icedrive\ Portable/Icedrive.png

Link to creation of executable desktop app

I scaled the icon to 64x58 points, then that size was displayed.
Plus put it in the same folder as the icon that was displayed.
Shouldn’t matter in which folder the icon is located, but was certainly dependent on the size? Get to test this with the third app then.

Moves the executable desktop file with the following command.

sudo mv ~/.local/share/applications/application-name.desktop /usr/share/applications/