How to change the load order of kernel modules?

I need to load amdgpu module before radeon module.
I tried to do /etc/modprobe.d/amd.conf:
blacklist radeon

sudo clr-boot-manager update

But it breaks of system

I have good experience to reorder this modules on ArchLinux this way:

This works (both settings required together):

blacklist radeon
# or so
#softdep radeon pre: amdgpu
sudo clr-boot-manager update

But Gnome on Wayland laggy for me