How to install LXC, a popular container technology

swupd bundle-add lxc lxc-templates
Loading required manifests…
Warning: Bundle “lxc” is invalid, skipping it…
Warning: Bundle “lxc-templates” is invalid, skipping it…
Failed to install 2 of 2 bundles

also, I tried to install unixodbc, in all variations, and could not find it. I installed dnf, but it does not work because dbus is not installed and dateutil is missing. So the question is, how do I install any package like MariaDB but the current version 10.6, and not the Clear Linux version, 10.4?
how do you install common packages like python 2 and 3?
I think I am missing something here