NVIDIA driver fails to install on native

Trying to install NVIDIA driver on Dell XPS 15 7590 with Geforce 1650 using Clear Linux documentation. I get following error:

WARNING: Failed to restore some backed up files/symlinks, and/or their
attributes. See /var/log/nvidia-installer.log for details

ERROR: Failed to run /usr/bin/dkms build -m nvidia -v 435.21 -k 5.5.2-903.native:
Kernel preparation unnecessary for this kernel. Skipping…

   Building module:
   cleaning build area...
   'make' -j12 NV_EXCLUDE_BUILD_MODULES='' KERNEL_UNAME=5.5.2-903.native
   IGNORE_CC_MISMATCH='1' modules...(bad exit status: 2)
   Error! Bad return status for module build on kernel: 5.5.2-903.native
   (x86_64)
   Consult /var/lib/dkms/nvidia/435.21/build/make.log for more
   information.

ERROR: Failed to install the kernel module through DKMS. No kernel module was
installed; please try installing again without DKMS, or check the DKMS
logs for more information.

ERROR: Installation has failed. Please see the file
‘/var/log/nvidia-installer.log’ for details. You may find suggestions
on fixing installation problems in the README available on the Linux
driver download page at www.nvidia.com.

Anyone else experiencing the same

1 Like

As this issue affects thousands of users, the expectation is that Intel stands up and talks to Nvidia to improve this unacceptable situation.

There is still a bug in CL regarding this topic. As reported on git, when you upgrade to Kernel 5.5 and later reboot into 5.4, you still can NOT build the Nvidia driver, which was working before with 5.4. So the 5.5 upgrade messed up the build environment for the 5.4 kernel, and the Nvidia users of CL are out of options.

Sadly the CL moderators just quickly close a git issue without proper reading what has been reported.

2 Likes

Im affected by it too. I dont think that it is totally related to Nvidia. My guess is that some flags are passed through to dkms.
I was not able to find anything about the flag “-mbranches-within-no-boundaries”
What I have found “-mbranches-within-32B-boundaries” AFAIK this is needed to mitigate the Jump Conditional Code Issue. https://www.phoronix.com/scan.php?page=article&item=intel-jcc-microcode&num=1

But “-mno-branches-within-32B-boundaries” does exist …maybe it is just some typo?

edit: it does exist https://github.com/clearlinux-pkgs/binutils/blob/f5fa47ed3a295ec067e27c8981c88aa8cbdc8166/0004-i386-Add-mbranches-within-32B-boundaries.patch

I think I have found the origin in binutils https://github.com/clearlinux/distribution/issues/1741

The fix listed in https://github.com/clearlinux/distribution/issues/1741 does not solve the problem unfortunately. I still cannot install the NVIDIA driver on native (same error).

It is fixed with the latest release you should be able to compile it. what is in the build log?

/var/lib/dkms/nvidia/435.21/build/make.log

1 Like

The fault was mine. I tried to compile with an older NVIDIA driver. Note: do not use NVIDIA’s search tool for specific GPU driver - just download the newest.

1 Like