Safe install error updating partition table

This is my first post and I want to emphasize that after initial testing Clear Linux seems very well done, particularly architecture wise, where there is a significant separation of system and user.
However I ran into an issue while trying to install in free space of hard disk selecting ‘Safe’ install.
Install fails with error seems to indicate a failure to update partition table. The number of existing primary partitions is 2, hosting just Windows 10, as I deleted remaining partitions, which were hosting Linux.
I tested on two laptops: Thinkpad t410 and X220. Same failure on installing.
Using another hard drive and using ‘Destructive’ installation (the entire hard drive) works fine and Clear Linux works as expected.
I will appreciate some advice how to resolve this Safe installation issue using unallocated space. From reading on the internet it is supposed to work…
Thanks and Regards…

This looks suspiciously like a bug if you got the same error on both systems. Did you verify the your iso download?

Yes. ISO is good and installs fine on the entire disk. Just not in the unallocated space. At first I though it needs more than two primary partitions to create but from what it says it needs just two, so it should work.
Clear Linux installed on the entire hard disk works great and is very impressive in terms of memory used.
Too bad it fails to install in the unallocated space in Safe mode… This would make a primary daily system for me…

I think there’s an advanced partitioning where you use gparted to manually make and assign partitions.

Yes. But Gparted started from that option just does what Gparted usually does, that means deletes and creates partitions. I did not see that this does anything special for Clear Linux. Besides, the unallocated space was already created by Gparted by deleting existing partitions.

Also, Clear Linux does recognize the unallocated space and chooses Safe mode of installation. All is fine until the actual installation, where it fails updating partition table, apparently to create its own partitions.

You can assign certain labels to the partitions to be used as root, swap, etc.

More details are in

From what I see Clear Linux install process is that it creates boot partition and root partition.

Read it. it’s pretty clear

OK. Let me go through this again.

Specifically, just this section

You’re only required to create a boot partition and root partition

Understood. However when I manually create these partitions installation does not allow Safe mode. Defaults to Destructive because it does not see unallocated space for Safe mode. If I select Safe option it does not allow to proceed with Safe installation.

Nah. Advanced Installation is a separate option to Safe and Destructive. You don’t need to choose Safe.

Yes it is. Advanced lets you use Gparted. It does not install. On Safe mode it says specifically that it will install in unallocated space. It says right there on Safe Installation option.

And it shows unallocated part of disk as it chooses to install, right next to Safe Installation option.

After creating and properly labeling partitions with gparted you then run install, you do not need to select safe. Sometimes after running your actions in gpated the installer window closes on you (this can be confusing I know) then you need to reopen the installer, but it should show your custom selection in under “Select Installation Media”. Just fill in your other options (time zone , user, telemetry, etc) and click install.

1 Like

I will try this again, but as I remember trying multiple times and creating two (primary) partitions CLR_BOOT and CLR_ROOT via Gparted, the installer (restarted) did not seem to proceed without selecting either Safe or Destructive (which I do not want if I can avoid).
Anyway let me re-do this …

did you save and run all your actions in gparted? or just close it? it doesn’t run all of your selections automatically, you need to run them in the end to finalize them with Select Edit ‣ Apply All Operations.

Just re-did. After creating labeled partitions restarted installer and if I select Advanced installation it says ‘No Media Selected’. There seems no option to select those labeled partitions for installation even rescanning.

Can you take a screenshot or a photo?