[SOLVED] CLR_MNT_ question yet again

:heart: CL so far!

TL;DR: only works setting /etc/fstab

I freshly installed CL (following the step-by-step instructions for installing Clear Linux OS) and after the reboot, look mom… no home :smiley:

As I prefer to have a separate home partition

  • I researched on search engine
  • searched for CLR_MNT_ in this forum
  • read a few links, among them The Discoverable Partitions Specification
  • I tried both the CLR_MNT_HOME and CLR_MNT_/home ways. Both return a partition type GUID 933ac7e1-2eb4-4f13-b844-0e14e2aef915 (should be right for home, right?). Example:
├─sda2 CLR_MNT_HOME 195.3G part 933ac7e1-2eb4-4f13-b844-0e14e2aef915 /home
$ sudo fdisk -l
Disk /dev/sda: 447.14 GiB, 480113590272 bytes, 937721856 sectors
Disk model: SanDisk SSD PLUS
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 1048576 bytes
Disklabel type: gpt

Device         Start       End   Sectors   Size Type
/dev/sda1       2048    307199    305152   149M EFI System
/dev/sda2     307200 409907199 409600000 195.3G Linux home
/dev/sda3  409907200 921905151 511997952 244.1G Linux root (x86-64)

Fact is, both fails to mount home. After the log in, I get the scary Oh no! Something has gone wrong message on blank screen and only option is to log out… :scream:

It works setting an /etc/fstab file and I could live with it, but I have the following curiosities (also, would like to follow the CL way):

  1. is that gpt type actually the right option in this case?
  2. is this setup correct and
    2a. should it work?
  3. what am I doing wrong?
  4. Any suggestion/how to fix it?

Thank you

It looks like you’re doing things right, at least with the partition type UUID. But there’s one case I know will break things quietly: If the /home directory on your root partition is not empty when the auto-generator runs, it will not create the home.mount virtual unit. Same thing happens for /boot, by the way (see Recovering from /boot weirdness).

1 Like

Thank you for the reply.

This would be my next question: the /home in root partition is not emptied because not accessible after reboot.

Of course I can empty it from the live USB, but I am also curious about how I could access those data from the actual installation.

Set a boot timeout, for example: sudo clr-boot-manager set-timeout 10

Reboot and interrupt the bootloader and change the init=... for your kernel command line to init=/usr/bin/bash to drop you straight into a root shell. You shouldn’t need /home to be available there, and you’ll skip systemd completely.

1 Like

THank you :white_check_mark: