Build 39890 - Login Issues

Tried build 39890 with the desktop live iso in a VM and it refuses to login. Running it live just shows the login button saying “Clear Linux” but it doesn’t do anything.

So I installed the known (to me) build that works (36000) and let it run the update.

So now I get my ID in the gnome login screen but the same effect. Clicking on the button does nothing.

I see that 39900 came out this morning. Let me try that one.

Instead of loading the desktop on the live CD, I get this auth screen in Gnome. When clicking on it, nothing happens.

(Build 39900)

What VM system/software are you running? VMware?
I am running VMware Workstation Pro 16.2. I could not run the Gnome-desktop from the console So I set up a vnc server to start a gnome-session. Prior to that, in order to install Clear-Linux I used the server ISO to install Clear Linux on the VM. In order to start up a VNC server I start the VMware session, and then I start a vnc session. I then log in with a vnc client and I can then access the gnome-desktop. In order to access the vnc server from another physical host other than the host running VMware I needed to forward port 5951.

The first round I tried the builds on my Proxmox host. When it bombed I tried again on my personal KVM desktop. Same results.

Build 36000 works just fine with live boot and install. It’s an old build, yes, but its my stable baseline at the moment. If someone can recommend a newer “stable” build to establish a new baseline, I am all ears.

I can’t check Clear every day, every week. I have to come back to it periodically and catch up on its progress.

I will give 37860 a whirl and see what comes of it.

Tried this and it appears to be working now.

Installed Clear Server 37860. Boot was stable. Login stable.
Ran the updates up to 39900. Boot was stable. Login stable.
Installed the bundle ‘desktop’. Boot was stable. Login stable.
Installed bundle ‘desktop-autostart’. Boot was stable. Login was stable.
Auto update ran after the reboot and put me at Build 39920.

Everything works. Hmm.
Let me try 39920 live-desktop.iso and see if it works as expected.

No Joy. 39920 desktop live boot gets hung up in the boot text mode and the screen starts flashing this warning (see images).

“workqueue: drm_fb_helper_damage_work hogged CPU for >18000ms 128 times, consider switching to WQ_UNBOUND”

In case anyone asks, here are the VM params.

Your summary of VM parameters look reasonable.
You did some good work here, submit your findings to Issues · clearlinux/distribution · GitHub.

You may be losing your patience in this process but if you haven’t you could look and see what os sub system has changed in the build numbers you have gone through. The Clear Linux build history, isos and reversion details can be found at Index of /releases/ (

Thanks I will research the changes and post on GitHub.

There is a lot of postings in the kernel website about changes impacting how workqueues are handled. Many of them started in late July. I suspect a patch in a release is causing havoc.

You could be right the kernel could have large impact on how x-windows and related kernel sub systems interact with each other. All I know is that my VMware session will not run a multi-user gnome-session from a console. I am at Clear Linux version:
swupd info
Distribution: Clear Linux OS
Installed version: 39930
Version URL:
Content URL:
I have swupd setup to auto update. My VMware session of Clear-Linux is not critical to anything I am doing right now, so I can allow it to update.

I am able to start a vnc session using gnome-session after logging in using a non gui based environment, i.e. an ssh console.

My setup crashed after trying invoke a gui environment via a “startx” command from the VMware console

That observed, I am able to log in via a single user vnc session, through a vnc client. From what I understand the way this works is that the vnc server is started creating “virtual” server. This enables a vnc client to connect into a gui environment. Not ideal, the way you were able to run things before things broke is the way things should work.