Cannot install with common NVIDIA 10-series GPU

Hi all!

I’m using an NVIDIA GPU. I know there are some problems using NVIDIA with Linux, but advice and workarounds seem to bounce around like a rollercoaster off its wheels, so I’m just going to ask the experts. (Also, see “updates” at the bottom for progress made.)

I’ve downloaded the 35000 release from the main page, and installation works – but updating breaks the graphics. (No, I never downloaded any drivers or proprietary blobs – I’m only using Clear Linux sources and defaults).

I’ve confirmed that downloading the latest ISO directly (Index of /current/ , 35650 at the time of writing) also leads to dead screen.

In the split second before it died, I noticed something pop up briefly about the EDID on HDMI1 (that’s the connector used for the monitor). There are no “onboard graphics” here. What can I do to get any sort of usable desktop after installing or updating to the latest release?

Some problems I’ve noticed:

  • SSH by hostname doesn’t work – and I can’t use IP addresses to the other nodes on the network because they’re dynamic. This seems pretty broken, and I’ve seen comments since 2019 about how avahi is totally broken and nobody fixed it. Still looking for the easiest way to be able to ssh into and out of the machine (as this is probably how most people would use Linux for dev work)
  • Timezone cannot be changed by the GNOME GUI. It keeps bouncing back to UTC despite me trying to select New York
  • Graphics are completely broken on common hardware, and no supported community repos or mechanisms exist to install (and keep installed!) proprietary drivers (which scared me off as it’s a multi-page laborious process with the stated caveat that things will break with every update).
  • Downloads are extremely slow. This has also been discussed considerably over the years and never fixed. The mirror (CDN) is simply terrible, and all mirrors in the swupd client point to the same place ultimately.

Some suggestions/solications for tips:

  1. There is a kernel flags field in the setup. Should I put something here? I’ve tried nomodeset to no avail, and not sure blacklisting nouveau is applicable since I never (got to) install a proprietary driver
  2. Is there a version known to work? Is the previous version workable? Anyone know which is the last working version so I can avoid updating further? (It takes a very long time to try each one as downloading is very slow, and flashing/installation each version takes an hour, too).
  3. Who is using this? How do others get it to work? Do you have to be deeply knowledgeable about the inner workings of the linux kernel to appreciate this distro, given lack of community repos and unfixed issues with ssh/dns, etc? Just curious so I know whether to hang on.

I’m eager to try out the purported performance improvements but can’t get off the ground with fairly typical hardware.

[Update 1]
Using the latest version’s ISO, I managed to boot using nomodeset and low userlevel into a text output. From there I tried installing the NVIDIA graphics drivers – some of the files mentioned in the tutorial weren’t present so I just did 2 steps:

  1. sudo swupd bundle-add kernel-native-dkms
  2. sudo ./NVIDIA-driver[…].run
    It worked with a reboot.

[Update 2]
Still struggling trying to connect to and from the computer from other computers on the network. I’ll open a new thread on this…

Resolved by much key-mashing and hours of trial and error installing with different boot flags. nomodeset was necessary, followed by booting using the UEFI shell within the bios to load the bootmgr.efi file directly on the hard drive, then jamming more keys until a terminal appeared for a split second, then typing in sudo init 1, then 3, then trying to get the ethernet network interface to work with something like sudo systemctl start NetworkManager.service, then letter-by-letter copying the download URL for the nvidia driver package into the terminal (I couldn’t just drop it in via SSH because Clear Linux does not support local SSH by hostname, and I didn’t have the current dynamic IP nor did I want to go through the hassle of setting up filesystem drivers to get my exFAT usb keydrive working), and finally wget-ing that link.

I then tried to follow the guide for getting NVIDIA drivers installed but quickly ran into trouble with paths that didn’t exist (again!), so just did:

  1. sudo swupd bundle-add kernel-native-dkms
  2. sudo ./NVIDIA-driver[…].run

It complained as it always seems to do, but after a reboot it all worked!! (Of course I also get a “Some system services need a restart.” message after rebooting, so maybe I need to reboot again and it’ll break again – but fingers crossed it won’t!

2 Likes

Solution for me on a few machines:

  1. Flash ISO from build 35730 and boot via USB live image
  2. Add nomodeset kernel flag in the installer’s advanced options, then install
  3. Download the NVIDIA driver binary from Firefox in the live image to formatted hard drive into the home folder (/home/[unsername]).
  4. Reboot. You may get a black screen.
  5. Hit Ctrl+Alt+F8 (try different F’s from 0 to 3 if nothing happens) until you get a terminal screen. Log in.
  6. Run sudo swupd bundle-add kernel-native-dkms
  7. Run sudo ./NVIDIA-driver[…].run (you can tab-complete the name after typing NVIDIA)
  8. In the installer, say “Yes” to installing DKMS modules and “no” the 32-bit compatibility libraries
  9. Ignore the errors and reboot

Everything should be working. Tested on 2 different machines with 10-series cards.

1 Like