Error to start AstroNVim in neovim

Hi all,

Yesterday I did a fresh install of ClearLinux, installed the neovim with swupd and tried to install the AstroNVim package of plugins ( . I did exactly as in the instructions.

git clone --depth 1 ~/.config/nvim

On nvim start, lazy plugin manager ( complains with a lot of error, like:

Error detected while processing VimEnter Autocommands for "*":
E5100: Cannot convert given lua table: table should either have a sequence of positive integer keys or contain o
nly string keys

and next:

Error detected while processing VimEnter Autocommands for "*":
Error executing lua callback: ...user/.local/share/nvim/lazy/alpha-nvim/lua/alpha.lua:714: attempt to index
local 'conf' (a nil value)
stack traceback:
        ...user/.local/share/nvim/lazy/alpha-nvim/lua/alpha.lua:714: in function 'start'
        /home/user/.config/nvim/lua/astronvim/autocmds.lua:248: in function </home/user/.config/nvim/lua

I have another installation of CL, that I use for about two years now, it is updated and nvim with astronvim just works fine.

My best guess is that my current installation is missing something. I installed lua-basic and devpkg-base bundles.

Any guess what I am missing?

Check the configuration files for the lazy plugin manager for correct values.

What happens if you disable some or all plugins, still errors?

@Businux thank you for the answer.

Even after disabling all the plugins I got some errors. Of course, the more plugins enabled, more errors.

Anyway, I just installed the pre-built package from and the astronvim works flawlessly.

My problem is solved, but maybe an issue in CL github should be created, since neovim is used by a lot of devs.

In addition, the neovim version in CL bundle is 0.8.3 and the last stable version is already 0.9.5.