Error when compiling older kernel


I am trying to compile older version of kernel. I have followed instruction the documentation in

I have noticed, if I compile the latest version it will compile fine. For example, right now the latest version is 5.6.15, it will compile fine. But, when I tried to compile 5.6.14, it will not compiled. Last week, I have tried to compile 5.6.14, and it was compiling fine because it was the latest version

Is there anything extra that I need to do that are not documented in the documentation?

Any help would be very much appreciated.

Thank You

What’s the error you’re seeing?

This is the error that I got when compiling kernel 5.6.10-947

…/arch/x86/kvm/…/…/…/virt/kvm/kvm_main.c: In function ‘__kvm_gfn_to_hva_cache_init’:
…/arch/x86/kvm/…/…/…/virt/kvm/kvm_main.c:2236:42: error: ‘nr_pages_avail’ may be used uninitialized in this function [-Werror=maybe-uninitialized]
2236 | for ( ; start_gfn <= end_gfn; start_gfn += nr_pages_avail) {
| ^~~~~~~
cc1: all warnings being treated as errors
make[3]: *** […/scripts/ arch/x86/kvm/…/…/…/virt/kvm/kvm_main.o] Error 1
make[2]: *** […/scripts/ arch/x86/kvm] Error 2
make[1]: *** [/builddir/build/BUILD/linux-5.6.10/Makefile:1683: arch/x86] Error 2

These are just warnings. The actual error probably happened earlier in the logs – search for “error:” and copy what happens around that.