Firefox, smartcard no access

I installed Firefox Bundles and smartcard bundles, but I can’t log into the websites that require access with Italian CNS smartcad. Firefox doesn’t go so far as to ask for the smarcard PIN.

What are the steps to install the libraries correctly to make them work with Firefox?

Thank you.

I installed the “smartcard” and “firefox” bundle.
I activated the “pcscd” service .
I ran the command: “pkcs11-register” which put the data in the “home/user/.mozilla” folder.
But firefox can’t get me to access the websites. The PIN is not asked and the page generates a card read error.

Where am I going wrong?

Check if the pcscd service is running : systemctl status pcscd.service

If it’s not running, start it with sudo systemctl start pcscd.service

Check if the PKCS#11 module for your smartcard is enabled in Firefox.

Go to Firefox’s settings, select “Privacy & Security”, scroll down to “Security Devices” and check if your smartcard’s PKCS#11 is listed and enabled.

Locate and delete the pkcs11.txt file in your ~/.mozilla folder and run pkcs11-register again.

Restart Firefox.

The pcscd in enable, delete only pkcs11.txt pkcs11-register does not recreate pkcs11.txt, but in firefox the smartcard is no longer associated. I manually re-associated the smartcard with the library
Restart firefox … not work.

The service status:
● pcscd.service - PC/SC Smart Card Daemon
Loaded: loaded (/usr/lib/systemd/system/pcscd.service; indirect; preset: disabled)
Active: active (running) since Fri 2024-05-03 13:15:52 CEST; 17min ago
TriggeredBy: ● pcscd.socket
Docs: man:pcscd(8)
Main PID: 3936 (pcscd)
Tasks: 6 (limit: 9100)
Memory: 1.1M ()
CGroup: /system.slice/pcscd.service
└─3936 /usr/bin/pcscd --foreground --auto-exit

mag 03 13:15:52 t440 systemd[1]: Started pcscd.service.
mag 03 13:15:52 t440 (pcscd)[3936]: pcscd.service: Referenced but unset environment variable evaluates to an empty string: PCSCD_ARGS

Open about:config in Firefox.

accessibility.force_disabled should be set to 0 / zero.

Restart Firefox.

Open about:support

Look for the Accessibility section and check for any errors or warnings related to the smartcard.

It does not work.
I installed Firefox from flatpak. Then the appimage, and finally the portable downloaded from the Firefox site.
For each I launched the service and the registration command but with none the PIN on the web page appears. :neutral_face:

In about:config, search for these settings :



Set both to true and restart Firefox.

(when not existing, create the key, as boolean type)

Not work.
security.enterprise_roots.enabled is true by default

this does not exist.

The question is:
With a fresh installation of Clear Linux Desktop,
Does Firefox work for someone with smartcards or not?

I upgraded clear linux and now the “pcscd” service went from version 2.0 to 2.2 and now it won’t start.
I think I have lost all hope.

Okay, thank you for your valuable help. I will reinstall the new version from scratch and try again, see if the service starts and if it works with the smartcard.
As soon as it’s done I’ll write the result, let’s hope well!

No dice even with a clean installation the pcscd service no longer starts, with a service not found error.

Then the installation from Ventoy gives error and the only way is with a USB stick to install the latest version.

I give up.

Some of the default build options changed in 2.2.0, including how the systemd service is configured (as a user service instead of a system service). I’ll change that back and get it into a future release.

Unfortunately, I have no hardware to do further testing with Firefox and a real flow.