Gnome NetworkManager changes?

I run Clear as a Development desktop. I’m on this machine all day every day and every hour I spend fixing things that mysteriously break is an hour I’m not being productive.

This morning I rebooted for the kernel updates (which were only made apparent after the gnome login window froze and I switch to a terminal tty, but that is a separate annoyance), and upon reboot, NetworkManager in gnome was no longer working as expected.

I have a number of development networks I VPN in to depending on specific tasks and I use the gnome NetworkManager to make it easy to switch networks, etc.

I found the following in my /etc/NetworkManager/conf.d folder:

user@Machine /etc/NetworkManager/conf.d $ head -n 1 systemd-networkd-unmanaged.conf 
# created by swupd on Tue 21 May 2019 08:04:20 PM EDT

If gnome’s NetworkManager should not be managing any of my network interfaces, then what should I be using? To get myself working today I commented out all of the lines of the file, but I would rather have the right solution in place. Any explanation or advice would be appreciated.

Hi Jeff;

could you please check if any files in the directory /var/lib/swupd/one-shot-updates exist (there should be either *.out or *.done file). Please post its contents here.

If there’s a .done file present, then please follow the procedure defined in man stateless:

sudo systemctl disable systemd-networkd
sudo systemctl stop systemd-networkd
sudo rm /etc/NetworkManager/conf.d/systemd-networkd-unmanaged.conf
sudo systemctl restart NetworkManager

Do you remember which version of the installer you used to initially install Clear Linux? We had an issue with a few version that were causing this retrofit to happen.

1 Like

kai,
Sorry for the delay.

var/lib/swupd/one-shot-updates # ls
201904-reconfigure-network-manager.sh.done
/var/lib/swupd/one-shot-updates # cat 201904-reconfigure-network-manager.sh.done 
ls: cannot access '/etc/systemd/network/*.network': No such file or directory
Created symlink /etc/systemd/system/dbus-org.freedesktop.network1.service → /usr/lib/systemd/system/systemd-networkd.service.
Created symlink /etc/systemd/system/multi-user.target.wants/systemd-networkd.service → /usr/lib/systemd/system/systemd-networkd.service.
Created symlink /etc/systemd/system/sockets.target.wants/systemd-networkd.socket → /usr/lib/systemd/system/systemd-networkd.socket.
Created symlink /etc/systemd/system/network-online.target.wants/systemd-networkd-wait-online.service → /usr/lib/systemd/system/systemd-networkd-wait-online.service.
Executed /usr/lib/swupd/one-shot-updates/201904-reconfigure-network-manager.sh on Tue 21 May 2019 08:04:20 PM EDT

I apologize, I don’t know what version for the installer I used. I only installed Clear 2 weeks ago, I booted from a live image on a thumb drive and installed from there.

I ran the commands as requested and, well, I don’t see much different. So hopefully everything is OK. I will try to reboot this weekend and I’ll let you know.

Thank you again for the help.

Hi Jeff;

we did track down and fixed the issue with sporadic NetworkManager retrofit. It’s fixed in the version 29680 (released today). From that version going forward, you will no longer experience the ethernet NICs being switched back to systemd-networkd.

1 Like

More details here (a github issue): https://github.com/clearlinux/distribution/issues/735

Great. Thanks again for the follow up.