Having boot issues when USB drives connected

Lately I have been having boot issues when USB drives are connected: some process hangs … or somethin’. I’ve noticed that this does not happen without the USB drives: the boot process is very smooth and fast. Anyway, thinking about disabling automount as a workaround, until this gets fixed. What would be the best way to disable automount in CL please?

Alright, this looks like it may have something to do with the org.gnome.desktop.media-handling automount and org.gnome.desktop.media-handling automount-open settings: does anyone know what difference there is between automount and automount-open? Anyone cares to explain?

With automount-open it will not only mount the media, but also launch a file browser window displaying the contents of the mounted media.

For disabling, use dconf-editor :

1 Like

Thank you. How come these are independent settings though? What happens if, for example, I set automount-open to on, but automount to off? Will the USB drive be automounted or not? (I am pretty sure that if they are both off, there will be no automount.)


And you can always create a command line alias or a Gnome custom shortcut to your own mount script.