Install brave browser

I tried that. But REMOTE_VERSION will get the latest release version number (it can be dev, release, stable or beta), not the stable release version number. :slight_smile:. And wget command fails for at least 3 versions.

The script will refer to this link https://github.com/brave/brave-browser/releases/latest to pick which release to install.
E.g.

  1. if the link point to Dev Channel, then “./install-brave-target.sh dev” will install development edition.
  2. if the link point to Nightly Channel, then “./install-brave-target.sh nightly” will install nightly edition.
  3. if the link point to Beta Channel, then “./install-brave-target.sh beta” will install beta edition.
  4. if the link point to Stable Channel, then “./install-brave-target.sh stable” will install stable edition.

In short, you need to goto https://github.com/brave/brave-browser/releases, verify the green “Latest release” label point to and install accordingly.

As of writing this, the latest release is v0.66.75. And it is the dev channel release. No way /install-brave-target.sh beta, /install-brave-target.sh nightly and /install-brave-target.sh stable commands work.

Correct me if I am wrong… :wink:

Yup. only ./install-brave-target.sh dev works. :slight_smile:

@MattiaVerticchio

So, How do we uninstall the Brave browser?:sweat_smile:

1 Like

You need to delete all entries where is make with rmp2cpio because brave-browser is not installed,we use the binaries.

if you uses the script to install,just delette the directory the script created。

@Adrian_K, Yes. I have deleted /opt/brave.com directory. That’s the path it is installed.

@hong.wei.phang, by the way the script doesn’t work at all. It has multiple dependencies to be resolved. Please run it in your system and make sure it works and kindly share the updated script as I am not good at that stuff. :slight_smile:

The script should be working as I use it daily. Can you tell me more details?Screenshot_2019-06-17_13-56-56

nayab : ~ $ ./install-brave-target.sh stable
Brave browser stable build updater
Local version : none
Remote version : 0.68.58
Enter to update, Ctrl-C to abort…
Downloading …
Targte to download not exist !
Please try ‘stable’, ‘beta’, ‘nightly’ or ‘dev’

nayab : ~ $ ./install-brave-target.sh beta
Brave browser beta build updater
Local version : none
Remote version : 0.68.58
Enter to update, Ctrl-C to abort…
Downloading …
Targte to download not exist !
Please try ‘stable’, ‘beta’, ‘nightly’ or ‘dev’

nayab : ~ $ ./install-brave-target.sh dev
Brave browser dev build updater
Local version : none
Remote version : 0.68.58
Enter to update, Ctrl-C to abort…
Downloading …
Targte to download not exist !
Please try ‘stable’, ‘beta’, ‘nightly’ or ‘dev’

nayab : ~ $ ./install-brave-target.sh nightly
Brave browser nightly build updater
Local version : none
Remote version : 0.68.58
Enter to update, Ctrl-C to abort…
Downloading …
brave-browser-night 100%[===================>] 73.50M 3.29MB/s in 22s
Extracting …
Done.

For nightly it worked because most of the times the latest release in https://github.com/brave/brave-browser/releases page is nightly release.

I think this thread has already become very long. Thank you very much for the script anyway.

I updated my response with the procedures for uninstalling both browsers. :smile:

I also replaced the wget command with curl, since the latter natively supports proxies and it’s already installed out of the box.

1 Like

For anyone interested — since I can’t edit my answer anymore — I opened two different threads for Brave and Chrome and updated the installation procedures with a more elegant solution that uses rpm instead of brutally unpacking the archive with rpm2cpio. It’s also more convenient for updating and uninstalling both apps.

2 Likes

So what is the correct command to update brave browser then? cpio -o?

… link - mattiaverticchio - “updating brave browser”. btw: they do it again.

I tried his suggestion - no luck

is the package-utils bundle installed? terminal - output? it works, i did it many, many times until i switched to another browser last week. step 1 -3 & commands one by one… .

Is this to update the brave browser or install it? I actually just want to update mine

What browser did you switch to? Why?

both. that’s the way to install it. that’s the way to update it. described by the author in the link:

“to update brave you can re-follow the procedure for installation, or periodically run it in a script.”

i switched to the ff - flatpak. many reasons. i guess, after this news, it was the right choice. but everybody’s free to do as they please.

It’s not working forme:

john@john:~$ sudo -s
root@john:/home/john# swupd bundle-add package-utils
swupd: command not found
root@john:/home/john# dnf config-manager --add-repo https://brave-browser-rpm-release.s3.brave.com/x86_64/rpm --import https://brave-browser-rpm-release.s3.brave.com/brave-core.asc

Command ‘dnf’ not found, did you mean: