Linux kernel 5.6 testing

Hi, has anyone tried to compile latest kernel for testing in Clear Linux with patches and built in wiregaurd?
Tried to build myself, had to disable patch 0116 and 1001(wg) and still no luck with

+ mkdir -p cpiofile/usr/lib/modules/5.6-926.native/kernel/drivers/hid
+ cp /builddir/build/BUILDROOT/linux-af-5.6-926.x86_64/usr/lib/modules/5.6-926.native/kernel/drivers/input/serio/i8042.ko cpiofile/usr/lib/modules/5.6-926.native/kernel/drivers/input/serio
cp: cannot stat '/builddir/build/BUILDROOT/linux-af-5.6-926.x86_64/usr/lib/modules/5.6-926.native/kernel/drivers/input/serio/i8042.ko': No such file or directory
error: Bad exit status from /var/tmp/rpm-tmp.bA31Ys (%install)

RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.bA31Ys (%install)
Finish: rpmbuild linux-af-5.6-926.src.rpm
Finish: build phase for linux-af-5.6-926.src.rpm
ERROR: Exception(results/linux-af-5.6-926.src.rpm) Config(clear) 22 minutes 0 seconds
INFO: Results and/or logs in: results/
ERROR: Command failed: 
 # /usr/bin/systemd-nspawn -q -M ee7f90f2f5b44a03bd8abf38f0666145 -D /var/lib/mock/clear-linux/root -a --capability=cap_ipc_lock --console=pipe --bind=/tmp/mock-resolv.ifw573xa:/etc/resolv.conf --setenv=TERM=vt100 --setenv=SHELL=/bin/bash --setenv=HOME=/builddir --setenv=HOSTNAME=mock --setenv=PATH=/usr/bin:/bin:/usr/sbin:/sbin --setenv=PROMPT_COMMAND=printf "\033]0;<mock-chroot>\007" --setenv=PS1=<mock-chroot> \s-\v\$  --setenv=LANG=en_US.UTF-8 -u mockbuild bash --login -c /usr/bin/rpmbuild -bb --target x86_64 --nodeps /builddir/build/SPECS/linux.spec

make: *** [../common/Makefile.common:88: build] Error 1
make build  8589,67s user 1081,48s system 713% cpu 22:36,23 total

You’ll need to inspect results/build.log to find the actual build errors.

1 Like

I don’t see any error prior install RPM step.
Here is the full info, with diff
PS Current kernel builds with no problem

Also I had to modify RPM specs to(not in docs)

%setup -q -n linux-5.6

Sir…compile kernel with patches first alone to assure there is no error with that…as far as i remember kernel compiling took from my pc longer that 22 minutes so maybe you got an error

It’s building just fine for 5.5 kernel, 22-24 minutes it’s ok for my CPU

If you look at our spec file, you can see that at this point (function createCPIO), we’re gathering keyboard drivers to put in an initrd. It’s possible that kernel 5.6 has changed the location where these drivers are stored, so you’d have to update their location in the spec file. It’s also possible that these drivers are not being built, for a different reason. There’s no info in the logs you shared to diagnose that, so you’d have to increase the verbosity of make.

If you don’t need the keyboard drivers initrd (I think we put that in there for handling LUKS-encrypted root partitions), then you might be able to just remove the cp commands in that function.

Yaeh, that’s first what I searched, did not find any info that something changed the location, what flags/option do you suggest to build commands to increase verbosity to know for sure where is the fail? As for these 6 drivers, if they are not so big maybe it’s possible to build inside kernel?

make help in the kernel source directory :slight_smile:
V=1 enables verbose output from kernel make

it was the path problem, my version was 5.6 but should be 5.6.0, btw 5.6.1 is out and it builds just fine without 0116 and wg pathces. Thanks for you time.

1 Like