Locate/mlocate change to findutils

It is my understanding that locate was removed and replaced with mlocate in the findutils bundle.
Today after the telemetry update, I no longer have locate on my system and I do not think mlocate has been installed… at least I can’t find it. :slight_smile:

I tried to remove the findutils bundle to reinstall it, hoping that might bring in mlocate, however this bundle is required by many packages. How do I go about getting mlocate installed?


The change was intentional. If you want locate, please swupd bundle-add mlocate. You’ll need to run updatedb as root once to create the database. After that, it’ll update every day.

Note: the bundle update and the package update were out of sync. Release 30440 is missing the bundle update, but it’ll be in the next one.

chris@envy~ $ sudo swupd bundle-add mlocate
Loading required manifests...
Warning: Bundle "mlocate" is invalid, skipping it...
Failed to install 1 of 1 bundles

I normally use a command like find . | grep font but tried locate and mlocate because I ultimately wanted to find gmone-font-viewer.

Sorry about adding to the TODO list. :laughing:

As I said, you need to wait for 30450 or later. The releases are blocked on Emacs+Vim vs GEdit discussion…