PHP is unable to locate pcre

Hi, I installed the following php bundles: php-basic, php-extras and php-basic-dev.

I ran the following command:
php -r "phpinfo();"

And I got the following error:
PHP Fatal error: Unable to start pcre module in Unknown on line 0

I’m assuming that the pcre module was already installed through one of the php bubdles. Do I need to configure something else to get php to run in the cli. As a side note, I am not going to be running php to serve a web app, I just need it for running arcanist

The only solution until the next release is to downgrade your system.

That can be done with

sudo swupd repair --picky -m [osversion]


sudo swupd repair -m [osversion] --bundles=[bundle1,bundle2]

Alright, thanks for helping me out.

if you are on 33250 and need to get the patch, and your system isn’t seeing an update, the fix that worked for me was:

sudo swupd repair -m 33260 --picky
  13 files did not match
    13 of 13 files were repaired

You can run

sudo swupd diagnose -m 33260

first see what to expect from the repair.

I did an update to 33260 just now and I’m not seeing the error anymore. :clap:

clearvm ~ » sudo swupd info
Distribution:      Clear Linux OS
Installed version: 33260
Version URL:
Content URL:
clearvm ~ » php -r "phpinfo();"
PHP Version => 7.4.5

Thanks for tracking this to resolution and relaying the information between the forums and GitHub @inmanturbo