VNC Server session "Oh no! Something has gone wrong"

Hello everyone, I am trying to give an “Intel Compute Stick” a second life, after using Ubuntu for a while, I thought that in regards of performance and processor compatibility Clear Linux would be a better choice.

I have just made a clean installation on my stick (core m3 model) and I am facing and issue when trying to connect using vncserver.

I followed up the clear linux online guide to deploy vncserver, but when I try to connect I see a full window stating “Oh no! Something has gone wrong”… does anyone knows how to fix this? :pensive:

This is my journal dump:

Jul 20 13:11:45 ICS wpa_supplicant[433]: wlp2s0: WPA: Group rekeying completed with 74:4d:28:f6:58:a2 [GTK=CCMP]
Jul 20 13:11:55 ICS dbus-daemon[954]: [session uid=1000 pid=952] Activating service name=‘org.gtk.vfs.Daemon’ requested by ‘:1.0’ (uid=1000 pid=941 comm=“/usr/libexec/gnome-session-binary --session=gnome-”)
Jul 20 13:11:55 ICS dbus-daemon[954]: [session uid=1000 pid=952] Successfully activated service ‘org.gtk.vfs.Daemon’
Jul 20 13:11:55 ICS org.gtk.vfs.Daemon[966]: fusermount3: failed to access mountpoint /run/user/1000/gvfs: Permission denied
Jul 20 13:11:55 ICS dbus-daemon[954]: [session uid=1000 pid=952] Activating service name=‘org.a11y.Bus’ requested by ‘:1.2’ (uid=1000 pid=964 comm="/usr/libexec/gnome-session-check-accelerated “)
Jul 20 13:11:55 ICS dbus-daemon[954]: [session uid=1000 pid=952] Successfully activated service ‘org.a11y.Bus’
Jul 20 13:11:55 ICS gnome-session[964]: *** MESA_GLSL_CACHE_DISABLE is deprecated; use MESA_SHADER_CACHE_DISABLE instead ***
Jul 20 13:11:55 ICS gnome-session[941]: gnome-session-binary[941]: WARNING: Failed to upload environment to systemd: GDBus.Error:org.freedesktop.DBus.Error.NameHasNoOwner: Name “org.freedesktop.systemd1” does not exist
Jul 20 13:11:55 ICS gnome-session[941]: gnome-session-binary[941]: WARNING: Failed to reset failed state of units: GDBus.Error:org.freedesktop.DBus.Error.NameHasNoOwner: Name “org.freedesktop.systemd1” does not exist
Jul 20 13:11:55 ICS gnome-session-binary[941]: WARNING: Failed to upload environment to systemd: GDBus.Error:org.freedesktop.DBus.Error.NameHasNoOwner: Name “org.freedesktop.systemd1” does not exist
Jul 20 13:11:55 ICS gnome-session-binary[941]: WARNING: Failed to reset failed state of units: GDBus.Error:org.freedesktop.DBus.Error.NameHasNoOwner: Name “org.freedesktop.systemd1” does not exist
Jul 20 13:11:55 ICS gnome-session-binary[941]: WARNING: Falling back to non-systemd startup procedure due to error: GDBus.Error:org.freedesktop.DBus.Error.NameHasNoOwner: Name “org.freedesktop.systemd1” does not exist
Jul 20 13:11:55 ICS gnome-session[941]: gnome-session-binary[941]: WARNING: Falling back to non-systemd startup procedure due to error: GDBus.Error:org.freedesktop.DBus.Error.NameHasNoOwner: Name “org.freedesktop.systemd1” does not exist
Jul 20 13:11:55 ICS gnome-session[941]: gnome-session-binary[941]: WARNING: Could not get session id for session. Check that logind is properly installed and pam_systemd is getting used at login.
Jul 20 13:11:55 ICS gnome-session-binary[941]: WARNING: Could not get session id for session. Check that logind is properly installed and pam_systemd is getting used at login.
Jul 20 13:11:55 ICS gnome-session[941]: _IceTransTransNoListen: unable to find transport: tcp
Jul 20 13:11:55 ICS gnome-session-binary[941]: Entering running state
Jul 20 13:11:55 ICS org.a11y.Bus[973]: dbus-daemon[973]: Activating service name=‘org.a11y.atspi.Registry’ requested by ‘:1.1’ (uid=1000 pid=987 comm=”/usr/libexec/gnome-session-failed --allow-logout ")
Jul 20 13:11:55 ICS org.a11y.Bus[973]: dbus-daemon[973]: Successfully activated service ‘org.a11y.atspi.Registry’
Jul 20 13:11:55 ICS org.a11y.Bus[1000]: SpiRegistry daemon is running with well-known name - org.a11y.atspi.Registry
Jul 20 13:13:06 ICS gnome-session-q[1004]: Failed to call logout: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name :1.0 was not provided by any .service files

Are you in an XWayland GNOME session? If so, switch to GNOME over X11 session once you click in the user name field of the GDM screen, using the button that appears. I don’t recall if that is available or not on the Live Image.

I was able to half get things to work under XWayland in Ubuntu, but it was a real kluge, and ugly.

1 Like