X Server terminated Error ~ Connection Refused

Yes that is there.

I mean Virtual

What virtual? Or Virtual what?

I mean not actually there and it manifests itself virtually. And for some reason didn’t happen on my system. [clr-boot-manager]

Anyway I get back on. And hit swupd update
There were abunch of errors around /var/lib/delta/XXXXetcc… lots of numbers

6 errors… I have pictures… And at the end more erros aboutnot being able to generate the boot file for the efi, systemd, efi_device path… about 4, said function not implemented…

( …/src/bootloaderz/shim-systemd.c:l285)

Please manually update your bios to add a boot entry for Clear Linux

I did a swupd verify --fix

It repaired 54 files a lot of /usr/lib64/…

Must be conflicting Clear Linux with Nvidia…

I reinstall Nvidia Driver

It encounters an error and says cannot create symlink with
/usr/lib64/libOpenCL.so

Sure enough x server fails again and spits something out about
/libatk-bridge-2.0.so.o
un defined symbol:
atk_component_scroll_to_point

What ever I uninstall and go to install 430.64

and get
/usr/lib64/libOpenCl.so
dose not point to
libOpenCl.so.1

And continues to say that that is necessary to operate the Nvidia driver

something about conflicting files that i didn’t have…
then
create symbolic link by running
ln -sf libOpenCl.so.1 /usr/lib64/libOpenCl.so

I do this and x server still terminates this time more of the same error unkown and not implemented… Also if I do a swupd repair it changes some of the /usr/lib64/… files that the Nvidia Installer added. X server still terminates no errors… I also got a refusal to connect in there. I’m at the point where I kind of want to just go back to nouveau… I don’t remember how to reimplement nouveau on this system. i didn;t ad a file called blacklist.conf to /etc/modprobe.d. I let the nvidia installer do it back in February and I can’t find what it did to undo…

I suggested that you should reinstall NVIDIA driver. I suggested you should uninstall the NVIDIA driver.

For uninstall, try this Bash scripts to automate installation of NVIDIA proprietary driver

I uninstalled it and reinstalled it multiple times and different drivers including: 440.31, 430.64, 435.21, & 4.18.30 w/ CUDA 10.1 update 2; but it couldn’t read the gcc version of the packet and wouldn’t install this newer version of CUDA. A simple sh ./NVIDIA-Linux-x86_64-xxx.xx.run --uninstall will take care of it. The swupd repair will revert everything else that it changed back to what ever they have on the clear linux server. Now I do not know how to re-implement the open source driver… Not that I want to. There is no /etc/modprobe.d/blacklist.conf or anything like it in that directory.

I tried the BASH scripts; indeed they are awesome, but I still am getting the exact same errors. I have .log files if that helps for XORG.

The uninstall script would restore everything.

It dose not, but I had Nouveau disabled by other means before I installed the Nvidia driver back in February. I did not add an /etc/modprobe.d/blacklist.conf. The nvidia installer disabled it by other means automatically and I do not know how to undo what it did. ( I think they ad another similar file in some other unbeknownst to me directory); sh./NVIDIA-Linux-x86_64-xxx.xx.run --uninstall dose not undo this. Now I need to re-enable nouveau. I mean I don’t want to really reenable nouveau as there is know open source vulkan driver anyway. Any more ideas on how to fix X with Nvidia Driver?

**uninstall.bash or cleanup dose not remove nvidia driver from dkms or that module… It still attempts to startx on reboot… I can re-execute bash scripts because of this dkms issue…

No fear swupd repair will fix that one.

Reinstall the OS seems to be the easiest way to restore everything.

I was afraid you would say that. I was trying to avoid it.

[   139.454] 
X.Org X Server 1.20.5
X Protocol Version 11, Revision 0
[   139.455] Build Operating System: Linux 5.3.5-847.native x86_64 
[   139.456] Current Operating System: Linux ryan 5.3.11-868.native #1 SMP Wed Nov 13 15:46:39 PST 2019 x86_64
[   139.456] Kernel command line: initrd=\EFI\org.clearlinux\freestanding-00-intel-ucode.cpio initrd=\EFI\org.clearlinux\freestanding-i915-firmware.cpio.xz root=PARTUUID=6e41e623-618f-4fa5-be1c-0fa0d7c58801 quiet console=tty0 console=ttyS0,115200n8 cryptomgr.notests init=/usr/bin/initra-desktop initcall_debug intel_iommu=igfx_off kvm-intel.nested=1 no_timer_check noreplace-smp page_alloc.shuffle=1 rcu_nocbs=0-64 rcupdate.rcu_expedited=1 rootfstype=ext4,btrfs,xfs tsc=reliable rw module.sig_unenforce
[   139.459] Build Date: 31 May 2019  06:47:02PM
[   139.460]  
[   139.460] Current version of pixman: 0.38.4
[   139.461] 	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
[   139.461] Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[   139.464] (==) Log file: "/var/log/Xorg.0.log", Time: Sun Nov 17 02:39:25 2019
[   139.464] (==) Using config file: "/etc/X11/xorg.conf"
[   139.465] (==) Using config directory: "/etc/X11/xorg.conf.d"
[   139.466] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[   139.466] (==) ServerLayout "Layout0"
[   139.466] (**) |-->Screen "Screen0" (0)
[   139.466] (**) |   |-->Monitor "Monitor0"
[   139.466] (**) |   |-->Device "Device0"
[   139.466] (**) |-->Input Device "Keyboard0"
[   139.466] (**) |-->Input Device "Mouse0"
[   139.466] (==) Automatically adding devices
[   139.466] (==) Automatically enabling devices
[   139.466] (==) Automatically adding GPU devices
[   139.466] (==) Max clients allowed: 256, resource mask: 0x1fffff
[   139.466] (==) FontPath set to:
	/usr/share/fonts/X11/misc/,
	/usr/share/fonts/X11/TTF/,
	/usr/share/fonts/X11/OTF/,
	/usr/share/fonts/X11/Type1/,
	/usr/share/fonts/X11/100dpi/,
	/usr/share/fonts/X11/75dpi/
[   139.466] (==) ModulePath set to "/usr/lib64/xorg/modules"
[   139.466] (WW) Hotplugging is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
[   139.466] (WW) Disabling Keyboard0
[   139.466] (WW) Disabling Mouse0
[   139.466] (II) Loader magic: 0x560d296d1020
[   139.466] (II) Module ABI versions:
[   139.466] 	X.Org ANSI C Emulation: 0.4
[   139.466] 	X.Org Video Driver: 24.0
[   139.466] 	X.Org XInput driver : 24.1
[   139.466] 	X.Org Server Extension : 10.0
[   139.467] (++) using VT number 2

[   139.469] (II) systemd-logind: took control of session /org/freedesktop/login1/session/_32
[   139.469] (II) xfree86: Adding drm device (/dev/dri/card0)
[   139.470] (II) systemd-logind: got fd for /dev/dri/card0 226:0 fd 12 paused 0
[   139.470] (II) xfree86: Adding drm device (/dev/dri/card1)
[   139.470] (II) systemd-logind: got fd for /dev/dri/card1 226:1 fd 13 paused 0
[   139.481] (--) PCI: (4@0:0:0) 10de:1c82:1462:8c96 rev 161, Mem @ 0xee000000/16777216, 0xd0000000/268435456, 0xe0000000/33554432, I/O @ 0x0000b000/128, BIOS @ 0x????????/524288
[   139.481] (--) PCI:*(5@0:0:0) 10de:1e87:3842:2183 rev 161, Mem @ 0xec000000/16777216, 0xb0000000/268435456, 0xc0000000/33554432, I/O @ 0x0000a000/128, BIOS @ 0x????????/131072
[   139.481] (WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
[   139.481] (II) LoadModule: "glx"
[   139.481] (II) Loading /usr/lib64/xorg/modules/extensions/libglx.so
[   139.481] (II) Module glx: vendor="X.Org Foundation"
[   139.481] 	compiled for 1.20.5, module version = 1.0.0
[   139.481] 	ABI class: X.Org Server Extension, version 10.0
[   139.481] (II) LoadModule: "nvidia"
[   139.481] (WW) Warning, couldn't open module nvidia
[   139.481] (EE) Failed to load module "nvidia" (module does not exist, 0)
[   139.482] (EE) No drivers available.
[   139.482] (EE) 
Fatal server error:
[   139.482] (EE) no screens found(EE) 
[   139.482] (EE) 
Please consult the The X.Org Foundation support 
	 at http://wiki.x.org
 for help. 
[   139.482] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[   139.482] (EE) 
[   139.483] (EE) Server terminated with error (1). Closing log file.

Actually, you can just sudo rm -rf /etc and reboot. NVIDIA Driver installer would change configurations in that directory.

I don’t remember what they did, but I think it was in /usr… anyway I restarted new OS 440.31 is up and running with kernel 5.3.11.868

Now CUDA…I go to website and use wget and sh, but it faills to get gcc version so I am unable to install it.

Also there is no nvidia-xconfig or nvidia-settings tool with the bash scripts… How do i get these two programs
?
I don’t need to download Nvidia CUDA tool kit do I for applications that have pre built dependencies to CUDA, do I?

You can follow the tutorial on how to install CUDA on Clear Linux.

If you installed the driver with my bash scripts, these two programs shall be found in /opt/nvidia/bin

What’s do you mean by pre built dependencies?

I just ran he pre and post install scripts and ran the nvidia installer normally… Worked fine.

I mean; I was wondering if you needed to download the CUDA tool kit for CUDA. Like having programs that use CUDA already. Do I need to download the CUDA toolkit since I am not developing anything. I learned that the answer is yes.

I followed the tuturial and it boils down to Segmentation fault at xxx line. I tried it several different ways. I’ll give it another go next week probably. Or see if Nvidia can do something about it. It’s there software. It should work.

Are you still getting this if you do sudo clr-boot-manage update? It sounds like this issue: https://github.com/clearlinux/distribution/issues/1468 and will not update your kernel

For future reference the nvidia installer drops the file in /usr/lib/modprobe.d/nvidia.conf. If you followed the documentation or @doct0rHu’s scripts this file doesn’t get added because we use the --no-nvidia-modprobe flag on the installer command line.

Try this: CUDA Toolkit Installation Error

My symbolic link gcc & g++ are broken. I used this command

sudo ln -s /usr/bin/gcc8 /usr/local/cuda/bin/gcc
sudo ln -s /usr/bin/g++8 /usr/local/cuda/bin/g++

The files are broken and nothing is in them when I open with text editor.

Do you have the c-extras-gcc8 bundle installed?

Yes, I have it installed and gcc7. I don’t know maybe it hasn’t registered correctly as I have reinstalled Clear Linux OS since on top of the old one. It keeps all the old packages. Maybe it hasn’t fully been reimplemented in my system yet. SWUPD knows it is there.

How did you reinstall your OS?

With the same USB I used to install it to begin with I made in October. The desktop gui version. Kernel 5.3.7… The first time I reinstalled it on an Clear linux partition I have been using for over a year an a half on a solid state drive. I had to reinstall everything. That one crashed and I reinstalled it again with the same USB. That time I didn’t have to reinstall any of the bundles. So I still have the original broken Clear linux with CUDA, don’t know if I’ll ever mess with it… That one first installed in Late January / early February with the old command text based installer.