Assistance building Gamescope from source

Ive been trying to build Gamescope for a few days now and keep running into issues.

As per the instructions on Valve’s Github Ive run the following commands

EDITED (I forgot to mention I ran this command without errors too):

git submodule update --init
meson build/

and received the following output

this is after using a number of “swupd search” to try and find missing dependencies as well as cloning and building hwdata.

As the output from that doesn’t seem to have any catastrophic errors I then moved on to the next lines

ninja -C build/

which gave a lot of errors, mostly seeming to take issue with the c++ compiler

pastebin part 1
pastebin part 2

It now appears that I am unable to continue any further with building this, so would like to ask for some help from the community.
Any suggestions for next steps to take? have I missed something obvious in my newness?
Thanks for reading

Got stuck in the same place as you are in. Tried checking out some older versions, no dice

1 Like

Figured it out
Under /usr/share/defaults/etc/profile
change out CXXFLAG -std=gnu++17 with -std=gnu++20
restart shell and try again.