Bootload manager errors

I have this errors when I run :

sudo clt-boot-manager update:
[ERROR] cbm (…/src/lib/bootvar.c:L319): blkid_probe_get_partitions() error
[ERROR] cbm (…/src/lib/bootvar.c:L319): blkid_probe_get_partitions() error
[ERROR] cbm (…/src/bootloaders/shim-systemd.c:L284): Cannot create EFI variable (boot entry)
[ERROR] cbm (…/src/bootloaders/shim-systemd.c:L285): Please manually update your bios to add a boot entry for Clear Linux

I run the 5.2.15-834.native kernel and cannot update to the latest kernel

sudo ctr-boot-manager list-kernels:

  • org.clearlinux.native.5.3.1-843

Are you on the most recent version of your bios?

yes,until now i dont have this issue.

1 Like

Hrm that’s interesting, the blkid_probe error makes me wonder if there is another problem other than the bios call not working. Mind adding an issue on github?

yes,but I dont know how :slight_smile:
OK ,done

1 Like

Thanks, we will move the discussion of the issue to over there. As an aside the 5.2 kernel is the latest kernel currently as we rolled back to it after seeing some issues with that 5.3 kernel so it isn’t showing a particular issue for you at this point.

You can see what Clear Linux thinks should be your latest kernel for a given type with the /usr/lib/kernel/default-{type} symlink (in this case /usr/lib/kernel/default-native).

ls -al /usr/lib/kernel/default-native
lrwxrwxrwx 1 root root 31 Sep 27 00:08 /usr/lib/kernel/default-native -> org.clearlinux.native.5.3.1-843

Here is the GitHub thread @Adrian_K created for reference:

cleaning /boot solve the issue,now all is ok(/boot was not emply when not mounted)