Clear Linux in Red

The following is what I see running Clear Linux using NVIDIA RTX 3070 with the Nouveau driver. What do you think? Fortunately, I’m able to install Clear Linux using the GUI installer. Not to worry, I have nvidia-driver-on-clear-linux to get the environment in good order.

Looks good to me?

Chris

Wow! The screen capture program captured the correct colors even though everything was red. I will take a photo next time. A couple of commands resolve the issue and now using the proprietary driver.

git clone https://github.com/marioroy/nvidia-driver-on-clear-linux

cd nvidia-driver-on-clear-linux
bash pre-install-driver
reboot

cd nvidia-driver-on-clear-linux
bash install-driver 510
reboot

I booted using the live desktop ISO. The following is what I see using RTX 3070. I can at least see the fonts and use the GUI installer. My prior card, RTX 2070, also appears red and worst (no fonts). That met booting with nomodeset and using the text-based installer.

Looks like there’s some legacy Red Hat code left behind. :slight_smile:

1 Like

This is a Gnome issue, mine just appeared again in upgrade.

  • Go to Settings > Color
  • The color profile may be set to your monitor (mine is LG). Expand the profile options and select the ‘add new profile’ button.
  • Select ‘Generic sRGB’
  • Delete the monitor color profile
2 Likes

Your tip works. I booted the live ISO image using the Nouveau driver. Could it be that the LG display supports 10-bit color? I had an old 10-bit Dell monitor that did the same thing.

The LG profile works using the NVIDIA proprietary driver. Sometimes I want to test the Nouveau driver and now know how to make the colors look right. Thank you!

That’s why I use KDE Plasma on Clear Linux instead of Gnome.

I don’t know if it’s LG specifically. I recall it’s a Gnome/xorg bug that keeps popping up from time to time.

Additionally, you can log in and select Wayland and it will display fine. My latest bug has a solid red screen, no tints and the only way I can fix it is to log in via Wayland and adjust the settings as above.

1 Like

Yes, I really don’t like Gnome. I thought KDE was unsupported. Maybe I’ll try that, thanks.