FFmpeg on Clear Linux including H.264 and VP9 acceleration

Sadly, am not sure how long but there was an incorrect setting for Firefox preventing it from decoding using hardware acceleration using NVIDIA graphics. The following was false in the documentation for some time. It must remain enabled (default) or decoding via hardware acceleration will not work.

media.rdd-process.enabled          true

I now verify libraries used. In the case of Firefox, I look for vdpau_drv_video.so or nvidia_drv_video.so while playing a video. Depending on using the vdpau-va-driver-v9 or the nvdec-enabled-vaapi driver, respectively.

$ lsof | egrep -e 'dri/vdpau_drv_video' -e 'dri/nvidia_drv_video'
1 Like

To be clear - the documentation you’re talking about is GitHub - marioroy/ffmpeg-on-clear-linux: FFmpeg on Clear Linux including H.264 and VP9 acceleration.

2 Likes

Correct.

I appreciate that you reach out @pixelgeek. There is another sadness of it all and it’s the swupd tool. It can break the NVIDIA driver installation. For that reason, I do not mention Clear Linux to my friends using NVIDIA graphics.

Otherwise if one doesn’t update (likely not recommended), the desktop experience is awesome. Even more so due to utilizing the video engine on the GPU. I enable ForceCompositionPipeline which rids of any jitters.

$ cat /etc/X11/xorg.conf.d/nvidia-screen-opt.conf 
Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option         "nvidiaXineramaInfoOrder" "DFP-2"
    Option         "metamodes" "nvidia-auto-select +0+0 {ForceCompositionPipeline=On, ForceFullCompositionPipeline=On}"
    Option         "SLI" "Off"
    Option         "MultiGPU" "Off"
    Option         "BaseMosaic" "off"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

There is happiness (what an amazing desktop experience) and sadness (dislike the swupd tool breaking the NVIDIA driver installation). I haven’t had the time to investigate ignore files.

Hopeful; ++ for the day the swupd tool is mindful of the NVIDIA driver installation.

3 Likes

Well, it’s a moment of celebration. :slight_smile: :sunny:

2 Likes

Any updates ?


Nothing that I can talk about yet :wink:

3 Likes

I downloaded the developer Chrome and automatically came with ffmpeg support and can watch youtube and such.

I ran the installation BASH and got one error this:

`ERROR: cuvid requested, but not all dependencies are satisfied: ffnvcodec
`