Fresh install experience

Hi everybody.

So i’ve been using CL for a year or so as a second boot on my computer.
I like trying out new versions but always go back to Windows due to stability issues
in linux DE.

My system specs are pretty basic.
Intel cpu i7 8086K. 32GB ram. Samsung M2 nvme drive. 27inch Acer Predator 165Hz monitor.
No other external cards. Using cpu built in graphics thru display port.

I will show you below my experience with a fresh install without thinkering alot.
Only software besides vanilla install is “Dash to panel” extension.

So install from USB works fine. No issues. I used encryption during install.
On first boot all is good.
The first thing i do is to change monitor refresh rate to get the smooth feeling.
Setting that and changing language then i go for a reboot.

Once i come back i notice on login screen the language have changed but the monitor
refresh rate is back to 60Hz.

So i login and try to set it back to 165Hz but there is no option for this anymore.
I can set maximum 99,95Hz. I set that and reboot.

At login screen it’s back to 60Hz again. After login it’s on 99,95Hz and then i go to monitor settings and there is 165Hz available again so i set it.

One more reboot and it actually is 165Hz.
Reboot again without doing anything else and it’s back to 60Hz after login.
I set it to 165Hz again.

After this i tought lets try other gui extensions. I tried Dash to panel and it suits me much better.
I disabled dash to dock. Looks great.
I reboot and all is gone. No dash no panel. Can not do much except using the right mouse click menu.
I logout then login. I get default gnome desktop.
Fired up settings by taking mouse to left upper corner and i see ALL extensions are disabled.
I enable them and all comes back as normal. Running at 165Hz. Fine. Lets reboot…
After login all works and i’m on 165Hz.Great! Lets reboot again…
Back on 60Hz and all extensions disabled. Means i have no dash or panel.
Another reboot and all is good.

Anyone knows what is going on here?
I mean this makes CL pretty useless as DE unless i have other hw issues i dont know about.

I have had a similar issue - using a 4K display that most of the time would be off, but gdm always running at boot - causing my screen to be 640x480.

One solution I found is to hardcode a virtual resolution and tell Xorg to use it at all times. Here’s what I used myself:


Section "ServerLayout"
	Identifier "Default Layout"
	Screen "TV"

Section "Device"
	Identifier "Intel HD Graphics"
	Option "monitor-DP1" "SAMSUNG"

Section "Screen"
	Identifier "TV"
	Monitor "SAMSUNG"
	Option "ConnectedMonitor" "SAMSUNG"
	SubSection "Display"
		Depth 24
		Modes "1920x1080"

Section "Monitor"
	Identifier "SAMSUNG"
	Option "enable" "true"
	Option "PreferredMode" "1920x1080"
	Modeline "1920x1080" 148.50 1920 2008 2052 2200 1080 1084 1089 1125 +hsync +vsync

As you can see, I’m forcing my 4K screen to 1080p because I only have 1080p content right now. This solves the issue for me.

If you capture and insert your 165Hz modeline here instead of my 1080p modeline, the monitor should always be in the one resolution you desire. You can use xrandr to view the modeline.

1 Like

Thank you for this tip. Works like a charm. Funny thing is that even settings works now and are nto reset
every now and then. I doubt it had anything to do with this but it works.
Only thing changed is new version of CL and your fix.

Thank you.