How-to: h264 etc. Support for Firefox (including ffmpeg install)

jl@clr-1ee3a8f796814644be5fa2cb94f4339f ~ cat /etc/ cat: /etc/ No such file or directory jl@clr-1ee3a8f796814644be5fa2cb94f4339f ~ cat {HOME}/.config/firefox.conf cat: /home/jl/.config/firefox.conf: No such file or directory jl@clr-1ee3a8f796814644be5fa2cb94f4339f ~

I can’t play some videos on Youtube, but not all. I’m going back to Kubuntu. I was going to try to use Clear Linux, but this is the straw that broke the camel’s back. I think it did work before, so I don’t know what is going on, but all this terminal buld stuff is beyond my capabilities.

Is not posible to have a ffmpeg CL package with: “Compile FFmpeg without “–enable-gpl” and without “–enable-nonfree”?”
Because : “x264 is a free software library and application for encoding video streams into the H.264/MPEG-4 AVC compression format, and is released under the terms of the GNU GPL.”

No, unfortunately it’s not that simple, otherwise, we would have already done that … 4 years ago or so.

Is it not possible to provide an extra non free repo like rpmfusion on Fedora ?

rpmfusion is not operated by Fedora. Fedora couldn’t for the very same reason we can’t.

Try the following

mkdir ~/.config
echo "export LD_LIBRARY_PATH=/usr/local/lib" > ~/.config/firefox.conf

Thanks for your help - there you go:

cat /etc/ /usr/local/lib /usr/local/lib /usr/local/lib cat ${HOME}/.config/firefox.conf
export LD_LIBRARY_PATH=/usr/local/lib
export LD_LIBRARY_PATH=/usr/local/lib

1 Like

jl@clr-1ee3a8f796814644be5fa2cb94f4339f ~ mkdir ~/.config mkdir: cannot create directory ‘/home/jl/.config’: File exists jl@clr-1ee3a8f796814644be5fa2cb94f4339f ~ echo “export LD_LIBRARY_PATH=/usr/local/lib” > ~/.config/firefox.conf
jl@clr-1ee3a8f796814644be5fa2cb94f4339f ~ $

Didn’t work. Plus I’m finding Gnome to be a clumsy desktop environment compared to most others.

jl@clr-1ee3a8f796814644be5fa2cb94f4339f ~ $ cat /etc/ /usr/local/lib /usr/local/lib /usr/local/lib cat ${HOME}/.config/firefox.conf
cat: /etc/ No such file or directory
cat: /usr/local/lib: No such file or directory
cat: /usr/local/lib: No such file or directory
cat: /usr/local/lib: No such file or directory
cat: cat: No such file or directory
export LD_LIBRARY_PATH=/usr/local/lib

Good or Bad? I still can’t watch html5 videos on Youtube. Back to Kubuntu which flows better and plays Youtube content out of the box.

Let me show you what I have:

$ cat /etc/ 

$ cat ~/.config/firefox.conf 
# ex: ts=8 sw=4 sts=4 et filetype=sh

export MOZ_USE_XINPUT2=1

export FIREFOX_INSTALL_DIR=${HOME}/.local/firefox

export LD_LIBRARY_PATH=/usr/local/lib

You should have alt least the /usr/local/lib in both files, the others are extras to my own setup.


Since I can’t dual boot Clear, I have to change my SSD card each time try to use it. I’m back on my Kubuntu card now, so testing Clear is not possible at the moment, and I’ve run out of patience. Plus as I mentioned above the work flow in Gnome is poor because the sidebar launcher doesn’t seem to come out over the top of FIrefox so switching apps is clumsy. The Destination Linux audiocast had a discussion on the benefits of GTK compared to Qt, and from their perspective GTK has none whereas Qt is cross platform. I’m just very frustrated and for my own mental health I need to stop messing around with Clear. at this point, it’s absolutely not worth the effort as it’s hard to use and at times useless. Another issue I discovered is you cannot even uninstall Firefox and reinstall it. I’m questioning if the entire concept of the project makes any sense at all for a desktop environment. It may be optimized for Intel processors but it’s far from optimum for end users.

Out of some weird reason, it is working now. Maybe, there was an update fixing some issues recently. In fact, I did not do nothing to change things…

I would also suggest installing the devpkg-libva bundle before building ffmpeg so configure will pickup on the vaapi hardware acceleration.

you can check if ffmpeg is build with support with the following

ffmpeg -hwaccels

Which should then have output like the following

ffmpeg version 4.1.4 Copyright (c) 2000-2019 the FFmpeg developers
  built with gcc 9 (Clear Linux OS for Intel Architecture)
  configuration: --prefix=/usr/local --enable-shared
  libavutil      56. 22.100 / 56. 22.100
  libavcodec     58. 35.100 / 58. 35.100
  libavformat    58. 20.100 / 58. 20.100
  libavdevice    58.  5.100 / 58.  5.100
  libavfilter     7. 40.101 /  7. 40.101
  libswscale      5.  3.100 /  5.  3.100
  libswresample   3.  3.100 /  3.  3.100
Hardware acceleration methods:

RPM Fusion is a community maintained project, not backed by Fedora or Red Hat, indeed.
If some wants to contribute build for clear linux, that’s someone that can be looked into.

What would be the preferred form for complementary build ?

  • RPM repository with few packages dedicated to clearlinux ?
  • an image overlay
  • else ?

/me is the RPM Fusion project coordinator.

RPM’s are not the preferred method here. Even flatpak would be better.

Thanks I’ll update the guide accordingly.

I’ve tried to rebuild couple of Fedora/SUSE packages on CL and seems like RPM/mock was highly patched: many macros doesn’t works and tons of another adventures.

anyone can help to run music with mp4a aac codec in clear linux?

Hi @YeQais and welcome. You could try installing the Celluloid (formerly GnomeMpv) Flatpak.

1 Like

Thanks. This worked for me. Firefox after installing ffmpeg now plays videos from it didn’t before.
Why does Eolie play these videos without ffmpeg?