I can confirm Kernel 6.4, KDE and Marioroy's Nvidia driver install scripts working

I followed these steps.

  1. Fresh install of https://cdn.download.clearlinux.org/releases/39590/clear/clear-39590-live-desktop.iso

Install it in text mode as it will not boot into GUI if you have a NVIDIA 40 series card.

  1. Follow steps as per @marioroy and additional steps. Thank you @marioroy

PLEASE NOTE!! This is only applicalble for a PC with a Nvidia 40 series graphics card not supported by the open source nouveau driver yet.

git clone https://github.com/marioroy/nvidia-driver-on-clear-linux
cd nvidia-driver-on-clear-linux
bash ./pre-install-driver update
bash ./pre-install-driver
bash ./install-driver latest
sudo swupd bundle-remove desktop-autostart
sudo swupd bundle-add desktop-kde
sudo swupd bundle-add desktop-kde-apps   # optional
sudo reboot

I have the best linux desktop now for the hardware I have. I tried Fedora, Ubuntu, Manjaro, Endeavor os, Arco, Nitrux, and some more!

Thanks for the heads-up. I don’t have Nvidia hardware but I do use KDE and it was broken with 39540. I hope it’s fixed now, will attempt to update to 39590.

[Edit]

Confirmed KDE working fine on 39590 with kernel 6.4.2-1331.native

SDDM was working, i was able to switch to xfce. Kde alone had issues.

You are welcome. FYI, I had to go to settings->appearance->global theme and choose Breeze again and apply to get all the desktop elements to appear.

@ItsJordan my guess the most important step for you is;

sudo swupd bundle-remove desktop-autostart

There are some minor flickering instances and app window disappearing, reappearing on the 4K screen. I am happy to cope :slight_smile:

This does not happen anymore in CL 39620. Yay :smiley: