Installing gentoo prefix in clear linux system

Dear All,

I am running clear linux on an amd64 FX 8350 box. I tried installing gentoo prefix https://wiki.gentoo.org/wiki/Project:Prefix
on it but got an error message from the prefix bootstrap script https://gitweb.gentoo.org/repo/proj/prefix.git/plain/scripts/bootstrap-prefix.sh
moaning about the CFLAGS and CCXFLAGS variables that are set in the bash profile file in clear linux and requesting that they be removed from the file etc. Running the unset command at the terminal before running the bootstrap script does not help.

The problem here is that the compiler settings are important for Clear Linux to deliver the fast optimisations it is famous for.

I thus worry that removing them from the profile file is a no-no here and so maybe I can’t really install gentoo prefix on a clear linux system - there is a compatability constraint here.

Comments appreciated.

Regards

Michael Fothergill

PS The clear linux bashrc profile file is here:

https://paste.debian.net/1091866/

The gentoo profile folks have suggested that I try adding the command

unset CFLAGS CCXFLAGS

as a new line at the end of the profile file and see if that helps get the gentoo prefix bootstrap script to run.

I tried this and gentoo prefix is installing…

I hope I haven’t deoptimised clear linux now.

Cheers

MF

The content that is distributed with CL is already built/compiled with those optimizations. So you should be free to change those environment variables shouldn’t be sacrificing any optimizations if you’re not planning on developing new packages.

Your change to /usr/share/defaults/etc/profile will get overwritten eventually. Add your change to /etc/profile.d/*.conf to make sure it persists. (see stateless).

Let us know how your experiences goes with Gentoo Prefix on CL.