Installing PlayOnLinux 4.3.4

Hi, I tried to install POL 4, since I personally don’t like POL 5, but when trying to install from the official page and run ./playonlinux, I get the following message:

Looking for python… 3.8.5 - skipped
Looking for python2.7… which: no python2.7 in (/usr/bin/haswell:/usr/local/bin:/usr/local/sbin:/usr/bin:/opt/3rd-party/bin)

Looking for python2.6… which: no python2.6 in (/usr/bin/haswell:/usr/local/bin:/usr/local/sbin:/usr/bin:/opt/3rd-party/bin)

Looking for python2… which: no python2 in (/usr/bin/haswell:/usr/local/bin:/usr/local/sbin:/usr/bin:/opt/3rd-party/bin)

Please install python before trying to run this program

I tried to install Python through Docker but that didn’t work.
Any ideas in how to fix it?
Thanks in advance.

Python 2 is deprecated. It won’t be available from swupd.

Consider to download a binary release of Python 2.

I managed to install it, and it worked to some extent, but I got the following error:
Looking for python... 2.7.18 - Traceback (most recent call last): File "/home/Milo/Escritorio/playonlinux/python/check_python.py", line 1, in <module> import os, wxversion ImportError: No module named wxversion failed tests
What could’ve caused that?

naturally, install it then

Well wasn’t so easy as i expected, but finally made it working (not tried games, but interfaces appearing).

You dont need the python2 as soon as they updated to 4.4 , they supporting 3.*

Installing all the prerequisite

sudo swupd bundle-add cabextract jq wine dev-utils wget devpkg-libpng devpkg-gtk3 devpkg-ncurses sqlite devpkg-openssl tcl-basic devpkg-readline devpkg-bzip2 devpkg-sqlite-autoconf devpkg-libffi devpkg-xz ImageMagick xterm

Installing ICOUtils

cd ~/Downloads
wget http://savannah.nongnu.org/download/icoutils/icoutils-0.32.3.tar.bz2
tar xf icoutils-0.32.3.tar.bz2
cd icoutils-0.32.3
./configure
make -j4
sudo make install

Installing wxPython and natsort (wxPython installation will take long time ~ 30m for me)

sudo pip3 install --upgrade --pre -f https://wxpython.org/Phoenix/snapshot-builds/ wxPython
sudo pip3 install natsort

Getting latest PlayOnLinux (4.4)

cd ~/Downloads
git clone https://github.com/PlayOnLinux/POL-POM-4
cd POL-POM-4
sed -i 's/version1\[0\]\.split(\"\.\")/version1\[0\]\.split\(\"a1\"\)\[0\].split\(\"\.\"\)/' python/lib/playonlinux.py

Last line is important , because otherwise it will cause error at version detection during the launch, it looks like i should commit patch to them.
Installing the snapshot version of wxPython is also important because last release not compiling properly.
Please test and let me know that everything working well.

3 Likes

Seems to work perfectly, thank you!

1 Like

Hi. When I install icoutils it shows me the following to finish “make”

gcc: warning: switch ‘-Wchkp’ is no longer supported
make[2]: se sale del directorio ‘/home/chucky/Descargas/icoutils-0.32.3/wrestool’
Making all in extresso
make[2]: se entra en el directorio ‘/home/chucky/Descargas/icoutils-0.32.3/extresso’
make[2]: No se hace nada para ‘all’.
make[2]: se sale del directorio ‘/home/chucky/Descargas/icoutils-0.32.3/extresso’
make[2]: se entra en el directorio ‘/home/chucky/Descargas/icoutils-0.32.3’
make[2]: se sale del directorio ‘/home/chucky/Descargas/icoutils-0.32.3’
make[1]: se sale del directorio ‘/home/chucky/Descargas/icoutils-0.32.3’

wxpython took more than 8 hours …

try to download the fonts, but i don’t get different results. And plaolinux shows wxpython unresolved dependency error of course.

wxpython on your page shows several alternatives, executing a script, with “pip” …

And the icoutils problem I don’t understand … does it seem like a problem in the compiler?

I need help, I am a mechanic, the last 10 years I used slackware and debian … I see this system very different.

By the way, my English is very bad.
Greetings from Argentina