Mozilla Firefox broke

Are you using the Firefox bundle or Flatpak ?

Bundle. Thing is, if I launch it in safe mode, it works, but in regular mode, even with all extensions disabled, it still broken. Ideas?

Anki had a problem for me where the application would react the same way as your Firefox, seems to be a glibc problem with older apps. Anki for example recommends using the beta version with uses Qt6 and doesn’t have this problem, or run the app in --no-sandbox mode. You can try that, run it un safe mode like you say, or simply using the flatpak version.
https://docs.ankiweb.net/platform/linux/blank-window.html

I guess it will get fixed in future releases.

No issues here with bundled FF 98 and 36010.

how did you install firefox beta?

I have the normal Firefox bundle but when I click the menu and go to “Help > About Firefox” the version number is 99.0b2 although the bundle version is 98.0 now

I did nothing to have the beta

Also when going to “Help > About Firefox” it’s updating itself to a new version when there is one independently of the Clear Linux bundle

Perhaps that’s how it became beta ?

I just downloaded 36070 to do a fresh install and it’s also exhibiting the same issue.

Do you know if the devs have been made aware of this?

No, sorry, I don’t know if that will happen. The other users here are reporting no problems with bundled Firefox, so it would seem that the problem is not on Firefox side, hence, there is nothing to fix actually.
I said that because I thought that it was a widespread problem such as Anki’s, but it seems it wasn’t.

I suggest that you try it on another PC, or try do a swupd repair, maybe also reinstalling Firefox to see if maybe some config from the app is conflicting. Honestly I have no idea what could be causing it, for this cases I just do trial and error until success.

EDIT: Just read that you actually did a Clean install… Hm… this is really weird, maybe it’s a driver thing issue? Honestly I don’t know what could be causing this, but only thing that comes to my mind assuming everyone else doesn’t have problems is some kind of incomaptibility with the hardware you are using and CL/Firefox.

It’s liveUSB CL 36070 running on a Haswell mobile i7-4810MQ/HD 4600, and Firefox is the only app with issues.
Anyway, I’m not savvy enough to find out what’s happening, I’ll just use Chrome.

1 Like

Try to make new Firefox profile, that’s help me

The solution is to disable “Use hardware acceleration when available”. Don’t ask me why, though.
Reminder that the issue also happens on v. 36070 liveUSB with no modifications whatsoever, so maybe it could affect other people still on Haswell?!

3 Likes

Same problem. i7 4700mq. Fix:

  1. firefox --safe-mode
  2. Settings → Disable Hardware acceleration

Flatpak version work normally.

1 Like

I use older machine i3-3217u can run it with hardware acceleration enabled

humm. even with use hardware acceleration enabled i need to set gfx.webrender.software to true

1 Like

Yes. With enabled gfx.webrender.software all work. Maybe it’s fixed in upcoming releases?

1 Like

I don’t know. I remember that first time install Clear Linux on my PC just work fine with the default setting.

Something broke along the way. I too didn’t have to disable hw_accel for it to work in installations leading to this one.

1 Like

I totally uninstalled Firefox and downloaded Brave Browser and everything just works all media on all platforms FB,Twitter,Tubi, YouTube.

1 Like

Hi All;

I’ve had problems with Firefox on my USB install media where it opens but does all kinds of funky things, like opens fully but plain white with no menu or buttons like close. And after installing Clear OS on my PC it does the same.

I went to the Software and installed it from there but it didn’t replace the original. So now when I need to start Firefox I have to go into Software>Installed>Search>Firefox>Open in order to get it to function properly. Once it’s opened I can click on the Firefox launcher icon in the system tray and it will show the open page in Firefox properly.

Question: How can I remove the original Firefox that came with the Clear Linux install as it’s not functional from the launch tray and how do I get to Firefox without going through the Software app to open it?

Thanks

Hi All;

I fixed the problem by removing the Firefox launcher and pinned a new Firefox launcher from the Software>Installed>Search>Firefox location and now it works. I decided to try the XFCE desktop and Firefox has the same problem where the launcher fails to load Firefox properly, it comes up but unusable. I tried launching it from the cli and got the following:
ATTENTION: default value of option mesa_glthread overridden by environment.
*** MESA_GLSL_CACHE_DISABLE is deprecated; use MESA_SHADER_CACHE_DISABLE instead ***
[Parent 1606, Main Thread] WARNING: Unable to connect to ibus: Could not connect: Connection refused: ‘glib warning’, file /builds/worker/checkouts/gecko/toolkit/xre/nsSigHandlers.cpp:167

(firefox:1606): IBUS-WARNING **: 14:59:33.240: Unable to connect to ibus: Could not connect: Connection refused
[2023-01-08T14:59:33Z ERROR glean_core::metrics::ping] Invalid reason code startup for ping background-update
[2023-01-08T14:59:36Z ERROR viaduct::backend::ffi] Missing HTTP status
[2023-01-08T14:59:36Z ERROR viaduct::backend::ffi] Missing HTTP status

So I went to the application finder and was able to launch Firefox from there.

Hope this helps anyone with similar experiences.

1 Like