No attempt to forward X over SSH has succeeded

Not with -X (untrusted). Not with -Y (trusted). Can’t generate a .Xauthority. Followed the instructions of https://docs.01.org/clearlinux/latest/guides/network/openssh-server.html and tried just about every suggestion I could find with Google–too many to report in detail.

Fedora (usually a pain because of security) and Ubuntu work right out of the box.

Our security policies here are the reason this does NOT work by default. This was a deliberate choice we made.

Read man stateless - it shows the exact changes needed to enable X11 forwarding properly in clearlinux.

I’ve opened https://github.com/clearlinux/clear-linux-documentation/issues/1027 to get the website documentation updated.