Login as root over SSH does not work

I have tried to enable the root login over ssh following the guide here: https://docs.01.org/clearlinux/latest/guides/network/openssh-server.html

However, it does not seem to work. Not sure why. I have no issues in logging in over ssh with another user. Sorry for asking this basic question, but I really don’t have any clue why this is not working.

As side info, I have noticed that if I try to login on the PC with Clear Linux (no ssh), in order to become root I first need to login with another user and then run sudo su. I’m sure that the password is right.
It seems that I cannot login directly as root.

Thank you.

After you configured it to permit root login, have you restarted sshd?

Yes, even though the guide that I have linked says it is not necessary.

Not really to solve your problem, but to avoid a bigger problem latter. Are you sure you really need root access via ssh? If the answer is yes, check your answer. Root access (and user) is disabled in most distros for a really good reason. Are you sure login with your standard user and then require root privilegies with sudo -i does not solve your problem?