Screen tearing on Intel Graphics

I unplugged my nvidia GPU due to the constant screen tearing (even with drivers installed) thinking that I wouldn’t have that problem using the Intel Integrated Graphics, unfortunately the screen tearing persists :frowning_face: . I’m using an Intel Core i7 6700k just in case.

Does anyone know how to solve it? Thanks!

press ALT + F2 and enter r

I did it. Sadly it didn’t fix it. :slightly_frowning_face:

Tearing can be due to many causes - screen size, hardware support for video decode etc. Can you explain exactly what programs are showing tearing, what screen resolution you’re using and maybe other relevant info?

My monitor is a S22F350 (22 inch) running at a 1980x1080 resolution, 60Hz refresh rate, connected via HDMI. Tearing occurs whenever I’m watching videos or even scrolling in web pages.

Can you post the output of lspci? What Nvidia card? What driver? Laptop or desktop?

This is the output

No nvidia GPU since I unplugged it. Drivers, the ones Clear Linux comes with I suppose because I did a clean install after removing the GPU. Desktop.

How are you watching videos? What player are you using? What kind of encoding?

Mostly YouTube and Netflix using Firefox. Haven’t really watched anything on my pc using gnome-videos or any other player.

You’re most likely using software codecs here - these may not have enough decode speed to do truly tearfree rendering.

I decided to try another browser (Chrome) and the tearing was gone, even when setting up the nvidia GPU and the drivers. Thanks for all the help and shame on Firefox.

One thing to keep in mind for good video is hardware acceleration which is through either VDPAU or VA. I haven’t had a chance to look into this on ClearLinux much but try this

vainfo

If the Hardware Video Acceleration library (libva) is installed then programs like VLC, mplayer, etc., will probably use it. Firefox does not. Chrome and Chromium do. For nVidia you’ll need VDPAU instead (export VDPAU_DRIVER=nvidia) and libva can then piggyback off of it.

ArchLinux has a good page on this:
https://wiki.archlinux.org/index.php/Hardware_video_acceleration

If you’re using the Intel i965 driver for X then ClearLinux sets up libva for you. I doubt for nVidia and I suspect no way for an Optimus based laptop.

1 Like

This isn’t caused by Firefox. They can’t really solve this problem. Only if content providers(youtube/netflix etc.) stop using proprietary media formats will the problem go away.