TeamViewer Host (general linux tar.xz package) - installation problem (architecture)

Hello,

trying to install TeamViewer Host (for unattended acces) on Clearlinux (currently 33340, very minimalistic, based on vmware image, running only nginx as a reverse proxy), but getting very strange error:

Your system architecture appears to be ‘x86_64’, but this package is ‘’.

Yes, I am using the right package (x86_64) and I also have tried i386 - the same.

Strange is the problem is not with linux architecture detection, but with the package detected as ‘’ by itself (???!!!)

Is there any trick, how to (temporarily) report linux architecture like ‘’ (to cheat on the package)? It looks it uses uname -m as a detection method (found in one of the configuration scripts)? Or any other method? Unfortunately the installer is binary file with no configuration options, only several basic commands (checklibs, install, install force) - all of them ends with the same error listed above.

Thanks!

S.

This is the wrong place to ask this very particular question regarding a proprietary software. You should contact TeamViewer’s customer support.

@sobik

Have you tried :

https://download.teamviewer.com/download/linux/teamviewer.x86_64.rpm

3 Likes