Nomachine anyone?

Has anyone attempted to install Nomachine lately? I know of some previous attempts, but those are quite old, and I was wondering if things have progressed as of late. Nomachine offers .deb, .rpm, and .tar.gz for download, and I am guessing .rpm would be the right choice, right? Sort of like this?

You might have to try it the old fashioned way. Typically to check on an application with Clear Linux I use the tarball and take on the errors one at a time to see what the app is looking for.

install from rpm is the easy way, but if it doesnt support realocation(from --prefix=/usr/local arg) the software likely will be deleted after executing sudo swupd repair

Okay, so I did a sudo rpm -ivh nomachine_8.4.2_1_x86_64.rpm and got a missing dependency:

dad@DadsGram~/Downloads $ sudo rpm -ivh nomachine_8.4.2_1_x86_64.rpm 
error: Failed dependencies:
	/bin/sh is needed by nomachine-8.4.2-1.x86_64

Is there a bundle that I may be missing?

a couple options:

  • swupd bundle-add shells
  • ln -s /usr/bin/bash /usr/bin/sh

if that doesn’t work, it’s a different issue. I’d try to avoid doing anything that modifies /usr/bin in general though. It seems that /usr/bin/sh (/bin/ is just symlinked to /usr/bin/ in Clear Linux) exists by default in the container, so I’d need to check on one of my physical systems later

Thank you! Yes, /usr/bin/sh already exists, and is already symlinked to /usr/bin/bash. As for installing the shells bundle, it also didn’t help: getting the same error after installing it. So it looks like the issue is deeper.

Ah, okay. Well I can’t help more with that atm then, sorry. I ran into that issue with something else too, not sure if I solved it. It’s odd for sure

1 Like

This is normal when attempting to install RPM(s) on Clear Linux. You want the --nodeps option to the rpm command.

rpm -ivh --nodeps nomachine_8.4.2_1_x86_64.rpm

Running rpm without the --nodeps option is the first thing to do, for checking the dependencies that the package expects. The /bin/sh file is not listed in the RPM database and the reason seeing the error. The error is safe to ignore as the file exist, so okay to specify the --nodeps option.

One may need to specify the --noscripts option in the event the script (if any), embedded in the RPM, is incompatible on Clear Linux.

Note: The RPM database and swupd data are not synced.

1 Like

Thanks. As a matter of fact that is precisely how I ran the rpm command the first time around (namely with the --noscripts and --nodeps options), and that based on one of your previous posts. And while the installation went (suspiciously!) well and fast, I have not been able to start the application, simply due to the fact that I cannot seem to find the nxserver file (which makes me think that the installation didn’t actually proceed properly at all).

The --noscripts option is needed when lacking compatibility for Clear Linux, which is the case for TurboVNC.

What about the nomachine RPM? One can obtain a list of files to get an idea of the content. Notice the list of files inside the RPM. This one prefers the integrated script to run, else what will extract the tar files?

$ rpm -qlp nomachine_8.4.2_1_x86_64.rpm

To save you time, the integrated script is incompatible on Clear Linux. Thus, unable to complete the installation fully.

The specified SYSTEM must be one of the following operating systems.
If not the NoMachine setup will try to autodetect the system or will choose
the layout that better resembles one of the known OS.

       redhat       Red Hat Enterprise 4 and later.
       suse         SLED 10 and later, SLES 10 and later, Open SUSE 10 and later.
       mandriva     Mandriva 2009 and later.
       debian       Debian 4.0 and later.
                    Ubuntu 8.04 and later.
       fedora       Fedora 10 and later.
NX> 704 ERROR: Unsupported operating system 'linux'.

Two working solutions were provided to you for Remote Desktop. I respect your choice for wanting Wayland compatibility. But that requires someone to implement Clear Linux compatibility, which is much to ask, assuming for free.

The other option is using a Linux distribution that is supported by the Remote Desktop application. Have you tried Remote Desktop on another Linux distribution?

I wish you all the bess.

This will place you on a better path. Basically, you want the tar file versus rpm. The installer has no clues about Clear Linux. To remedy this, specify fedora so that the installer has an idea of what the system closely resembles.

NoMachine expects its files residing in /usr (e.g. /usr/NX). Therefore, the -C /usr argument is specified to the tar command.

Attempting to install to another location will cause the installer script to partially fail. Unable to install to another location is a regression on their side (e.g. NX_INSTALL_PREFIX=/opt). Something or awk may fail due to looking at /usr/NX. For that reason, I recommend installing to /usr.

# First, create the /etc/pam.d directory (important).
sudo mkdir -p /etc/pam.d

# Obtain and extract the nomachine tar file, from
sudo tar xf nomachine_8.4.2_1_x86_64.tar.gz -C /usr

# Installation.
sudo /usr/NX/nxserver --install fedora

# Disable/enable VirtualGL.
sudo /etc/NX/nxserver --virtualgl no/yes

# Audio support.
sudo /usr/NX/scripts/setup/nxnode --audiosetup /usr/share/pulseaudio

# Printing support. Note: This does not work ???
sudo /usr/NX/scripts/setup/nxnode --printingsetup /usr/share/cups

# Start the service.
sudo systemctl start nxserver.service

# Check the status.
sudo systemctl status nxserver.service

If you want, possibly reach out to the NoMachine folks about Clear Linux resembling Fedora Linux (e.g. using systemd). Provide also the audiosetup path. Maybe more companies will support Clear Linux. It requires the first step, reaching out. I did so for RealVNC (VNC Server/Connect) and TurboVNC.

# To uninstall NoMachine (e.g. to start over if needed).
sudo /etc/NX/nxserver --uninstall

Unfortunately, sound doesn’t work for me. I tried various things to improve performance. I am sadden that you did not try TurboVNC.


I did create the /etc/pam.d directory, though I notice that the installation script complains about:

/usr/NX/scripts/setup/nxnode: line 11168: /usr/etc/pam.d/su: No such file or directory

Is that something I should be worried about?

I’m not sure. The pam.d su modules lives in /usr/share/pam.d/. I installed NoMachine, just enough to provide instructions. Have you tried connecting remotely? NoMachine is slow compared to TurboVNC. I did not investigate further, but gave it a spin.

Thanks to your instructions, I sorta managed to make NoMachine work! I say that because I am unfortunately getting a blank screen on the client side, but I can control the mouse! Anyway, I went with “yes” for --virtualgl, and that may be why I am getting a blank screen. I’ll try it tomorrow with “no” for --virtualgl.

I’m not sure. I have already removed NoMachine. Wayland may be partially supported.

With the latest CL updates (38680?), NoMachine is now actually working!!! Many thanks for your help @marioroy!