Update warnings

Why am I getting these warnings?

tymike@mikePC2~ $ sudo swupd update
Update started
Preparing to update from 38640 to 38660
Warning: Bundle "devpkg-mozjs78" is invalid, skipping it...
Warning: Bundle "devpkg-atk" is invalid, skipping it...
Warning: Bundle "devpkg-at-spi2-atk" is invalid, skipping it...
Warning: One or more installed bundles are no longer available at version 38660

Looks like there was some oddness in your format bump. If you remove the offending names from /usr/share/clear/bundles you’ll be back to normal.

Same issue here :

$ sudo swupd update 
Update started
Preparing to update from 38640 to 38660
Warning: Bundle "devpkg-atk" is invalid, skipping it...
Warning: Bundle "devpkg-at-spi2-atk" is invalid, skipping it...
Warning: One or more installed bundles are no longer available at version 38660

Same here, but a bit different. How can I please get rid of these annoying warnings and fix my distribution ?

$ sudo swupd repair
Mot de passe :
Diagnosing version 39690
Downloading missing manifests…
Warning: Bundle “postgresql13” is invalid, skipping it…
Warning: Bundle “postgresql12” is invalid, skipping it…
Warning: Bundle “postgresql11” is invalid, skipping it…
Warning: Bundle “devpkg-atk” is invalid, skipping it…
Warning: Bundle “devpkg-at-spi2-atk” is invalid, skipping it…
Warning: Bundle “conda” is invalid, skipping it…
Error: Unable to verify. One or more currently installed bundles are not available at version 39690. Use --force to override
Repair did not fully succeed

swupd bundle-remove the bundles listed as they no longer exist on the latest format.

I tried it but :

Blockquote $ sudo swupd bundle-remove conda
Warning: Bundle “conda” is invalid, skipping it…
Failed to remove 1 of 1 bundles

giphy-1842133075

2 Likes

1 Like

You can either force or just directly remove the tracking file on the filesystem in /usr/share/clear/bundles.