39530+ no USB drives

Starting w/39530 my CL no longer detects USB drives. Anyone else noticed that?

Could this be due to the new 6.3.10 kernel introduced in 39530?

Now you have mentioned it, I can confirm.
The USB drives are still recognized though, it’s only that they do not get automatically mounted on /run/media. You can still mount them manually.

I’m kind of old school and never liked this auto mounting in the first place.
Alas, it will get corrected soon.

1 Like

Now, before posting the OP I did attempt to check in “Disks” if the USB drives show up, but “Disks” just wouldn’t start (or it crashes upon start), so I concluded that something deeper must be rotten with 39530+.

So, before I attempt to update to 39540, would you mind checking if you can start “Disks” please?

Indeed, “Disks” crashes.

What about lsblk? That’s my goto Thanks for the heads up. Today is Friday so I will be updating
one of my Rescue USB disks to see if there are issues.

Has anyone restored back to last known Clear Linux build with swupd and/or boot with earlier

I restored back to version 39490 with swupd repair , gnome disks works there.

1 Like

See also this.

Just updated with swupd
“Preparing to update from 39430 to 39540”
Auto mount function is missing. Have to mount directly using mount from command line or put the disk entry in the /etc/fstab. note use /dev/disk/by-uuid for the disk you want to mount. If
you use the /dev/ this will fail from boot to reboot. Using device ID will
guarantee you mount the device you are expecting.

Just to confirm gnome-disks is failing. Console message shown:
(gnome-disks:3038): GNOME-Disks-ERROR **: 13:20:30.123: Error getting udisks client: Error calling StartServiceByName for org.freedesktop.UDisks2: Failed to activate service ‘org.freedesktop.UDisks2’: timed out (service_start_timeout=25000ms)

This a simple bash script to mount a USB drive
To get a get a good set of options do a grep on mounts. Below is an example of how to find
your mounted drive
sudo mount | grep -i easystore
/dev/sdc1 on /mnt/easystore type ext4 (rw,nosuid,nodev,relatime,errors=remount-ro,stripe=256,uhelper=udisks2)


The following options can be found if the drive was automounted or a root user

mounted the drive as mount /dev/ /mnt/

in the system generated file “mounts”


this device id helps select the currect USB drive

every boot cycle

mount -t ${fs_type} -o ${options} ${devID} ${mount_pt}

“Clear Linux is designed to be a rolling release distribution: always looking forward, not backward.”

How did you manage to roll back, could you elaborate please? I’m also looking for swupd logs to check which version i was running prior to the last update. Thanks.

Edit: Too late, i already did a popo:

sudo swupd repair --picky

Inspected 338530 files
145 files did not match
145 of 145 files were repaired
0 of 145 files were not repaired
3234 files found which should be deleted
3234 of 3234 files were deleted
0 of 3234 files were not deleted

Calling post-update helper scripts

You can go back to a version using swupd with the command
sudo swupd update --version
with @sluke2210 suggested version 39490.


swupd update --version 39490
Update started
Error: Requested version for update (39490) must be greater than current version (39540)
Update failed

swupd repair --picky --version 39490

This one “worked”. Will see after it finishes if the system survives looking backward for a while

1 Like

Looks like it’s been fixed in version 39590

Agree with @sluke2210 the auto mounting of USB drives with gnome has been taken care of. I noticed many changes for example emacs appears to show all that is loaded if it is invoked. All of the libraries and user configuration is echoed in the shell. I mention this because it new and different.

1 Like