A sad story about the first acquaintance with CL

I just want to tell my sad story.

With the acquisition of a new hard-system, I decided to time the fulfillment of two my desires. First, get a Mini-ITX hard-system. Therefore, it became this:

ASUS ROG STRIX B560-I GAMING WIFI
Celeron G5905
One plank Crucial DDR4 32GB 3600MHz Ballistix

Second, migrate to Linux. What is more, on CL, because I thought that Linux from Intel would work better with Intel products. Therefore, I tried to start live-usb CL Server 34500. But the screen only blinked for a split of second with the output that is quite usual for this case:

[] mce: [Hardware Error]: CPU 0: Machine Check: 0 Bank 6: ********
[
] mce: [Hardware Error]: TSC 0 ADDR ****** MISC ********
[] mce: [Hardware Error]: PROCESSOR 0: ****** TIME: ******** SOCKET 0 APIC 0 microcode e0
[
] ACPI BIOS Error (bug): Failure creating named object [_SB.PCIO.PEG1._PRT], AE_ALREADY_EXISTS (/dswload2-326)
[
] ACPI Error: AE_ALREADY_EXISTS, During name lookup/catalog (*******/psobject-220)

after which the computer did not stops as such, but stopped sending a signal to the monitor. The half-hour wait did nothing. With the Desktop version happened the same. Neither updating the BIOS, nor disabling Fast/Secure Boot, did change anything.

I had a live-usb Debian 10.* Standard, a live-image run in text mode. It started up. But the gnome-versions of both this Debian release and the newest release, as well as the latest Debian release with the third version kernel, gave the same unfortunate result as CL.

I even doubted the functionality of my hard-system. But Windows 10 installed and worked without problems.

While I was experimenting, there was a new CL release and I tried again. With the same effect. Then I, on good advice, removed “quiet” from the boot parameters and added “nomodeset”. Oh, miracle! - as a result of many lines and fading after the audiojacks definition, from which the process was possible to wake up only by pressing Enter, the prompt line appeared.

I tried to install CL. But at the Select Installation Media stage, only the Destructive Installation mode was activated. It was impossible to activate other modes. But I needed the Advanced Installation mode.

Then I got insolent and entered “startx”. Oh, the second miracle! The gnome started up. True, in a very truncated and simplified appearance. The sidebar was missing, the top bar was gray, and instead of the Activities label, there were two other shortcuts Application and Places. Some applications were missing and others didn’t work. For example, there was nothing to open the Places shortcuts. And there was no CL installer shortcut. But there was a mention of it in the application Applications (sorry for the tautology). That is, the application seemed to be there, but it was impossible to run it.

I took the nerve again and wrote “sudo clr-installer-gui”. Oh, the third miracle! The application has started. And there, as I expected, any installation mode could be activated. Luckily DParted worked too and I installed CL as I wanted. But alas! Installed CL worked the same as the live image: no boot - change of parameters - startx - trimmed gnome.

There were only two ways to check the principal my hard-system compatibility with *nix. Either Ubuntu, which is the most popular and heavily supported, or NetBSD, which is said to run on anything that moves.

A fresh gnome version of Ubuntu live launched, installed, and work. But that’s not what I wanted. Hopefully CL gets the same ability and I can install it.

CL is not intended for beginners of Linux system.

But meanwhile it shouldn’t be so difficult to start the live CD…

This might be not what you expect, though I would like to suggest installing Clear Linux OS as a virtual machine as Hyper-V, VMware or WSL on Windows. Thanks to abstraction of hardware layer by virtualization, they would make installation barrier from unenexpected things as you experienced milder. And UX on a virtual machine may help to familiar with Clear Linux OS.

My 1st step was to install desktop image to Hyper-V VM on Windows. And installing it on WSL was my 2nd step as this.
https://impsbl.hatenablog.jp/entry/ClearLinuxOnWSL2_en

Clear Linux OS is focusing for server and cloud, though they provides bundles for desktop. And actually, Clear Linux OS in not intended to suitable for novice end user as me. And their main target is looks like this.
https://docs.01.org/clearlinux/latest/about.html#target-audience
https://docs.01.org/clearlinux/latest/reference/tutorial-ratings.html

1 Like

Dear espio999, thanks for the advice. However, the CL interests me exactly as a means of getting away from Windows.
As for the fact that the CL is not a system for beginners, then as conceptual designer I can say that’s not the point at all. The fact is that any thing is only a function that this thing provides. And if a thing does not provide the only - its single function, then this thing does not seem to exist. Therefore, any thing must first simply function, and only then possess some specific properties (for beginners, for olders, be green, be long, etc.) Unfortunately, the Linux world is far from this now. Many new options are included without worrying about the functionality of the OS as a whole. For example, even in the same Ubuntu that was previously working out of the box, now I am faced with a problem where none of the many tutorials helps to completely set up Samba. This can still be understood when the system is being developed by a group of enthusiasts. But when it comes to a name like Intel… I have always been an admirer of Intel and I try to use the products of this manufacturer whenever possible (I can only regret that I can no longer buy Intel motherboards). I just expected otherwise.

Although focusing point is different, we have common goal → getting away from Windows. Though, my target is note PC, not desktop.
And I synpathize this → “I can no longer buy Intel motherboard”

Probably, Intel NUC would be perfect fit for your purpose, though it may be too late.

Good luck.

First, you should never expect anything work out of box. If you do, use Windows.

LoL turn down 4what… on a serious note, that’s sadge.

I would also prefer a portable device, but the NUC form is limited in freedom of configuration little more than I would like.

First, do you agree that nothing should work normally? Except Windows?

I assume everything is broken. I had said this for many times on different occasions.

If you haven’t paid, you cannot complain.
Suck it up.