Cant boot/install CL Desktop on g3258 (haswell)

Hello, found weird problem - i am trying to install CL on some kind of old hardware , there is a specs:

Server version installs and working absolutely fine on lts kernel (on latest kernel (5.8+) i have some problems with realtek ethernet , so i switched to lts and its fine). But , when i trying to install Desktop version i’ve got a weird problem - installer tried to start, but then “freezing” after trying on launching gnome (screen is black, mouse cursor appearing just for few seconds). Also i can see for 1 seconds login screen where is instead of user icon “not listed” text.
What i tried:

  • Fedora 32/33, ubuntu 20.04 desktops working fine
  • Installed CL server, then installed desktop over it - result are the same
  • My assumption was that something wrong with Intel HD , i am installed external GPU, nothing changed
  • Installed ESXi 6.7 over this small box, and tried to create VM with CL Desktop - installer launch with the same result as on baremetal
  • Tried different versions of CL like 31000 -> 33700, all the same, older version not working because of AES
  • Compatibility script says that my HW is OK

I will try to find something in the logs.
Ok there is a logs:
First output of journal taken before disabling wayland, second after. Error could be found by “systemd-coredumd”
1st:


2nd:

Also i recorded video how it looks like:

(at the end i am pressing ctrl-alt-f2)

update:
i started X with startx but it crashed very fast, and looks like it quite buggy
Video:


Error:

The default kernel for desktop is kernel-native. That could be the cause.

switched to native, the same result

That processor does not support AES new instructions so it’s not compatible with Clear Linux. See https://ark.intel.com/content/www/us/en/ark/products/82723/intel-pentium-processor-g3258-3m-cache-3-20-ghz.html

As far as i know AES prereq was removed , some time ago:

Also here:

AES specifically is not needed but pclmul is which Intel released with AES-NI beginning in 2010. It seems if the processor does not have AES-NI there’s a good chance (100%?) it will not have pclmul and therefore won’t work with Clear.