Can't start up CL on HP Envy 13 ba1000 i5 1135g7

Hi everyone!

I want to start this topic by stating that this is my first post in the community so please be nice if I make any mistake, I’ll try to amend it.

I’ve been using CL on an asus e200ha (atom x5-z8350) which run flawlessly in such low power hardware.
The emmc on that device died, so I decided to buy a new PC. The new PC is HP Envy 13 ba1000 i5 1135g7, I wanted to install CL and run it on this new device.

I downloaded various CL versions and tried to install them but couldn’t make it.

With versions older than 2020 the installation process wouldn’t even begin, but for versions later than 2020 let’s say 32200 or even the latest one 34620 the installation process does finish correctly.
But when trying to startup the system I get these 2 lines

sd 0:0:0:0: [sda] No Caching mode page found
sd 0:0:0:0: [sda] Assuming drive cache: write through

and then a hyphen blinking for a few seconds just to stop blinking and having to do a hard reset.

I don’t know if this hardware is already supported maybe I just have to wait. What make me suspicious is that the OS was able to live boot, recognized the drive and finished the installation. But during startup it freezes so I think maybe I missing a step or something.

if anyone has any idea how to solve it will be greatly appreciated.

Thanks everyone for the time and I hope this can help someone else with the same problem.

CL rocks!

Hello Francisco, welcome to the forum.

Did you update your BIOS, and disable secure boot ?

1 Like

Hey thanks for the quick response. I checked the BIOS and it was one version behind. I updated it and tried again.

Now I don’t get the Caching messages but is still stuck with the hyphen blinking.

I disabled secure boot as it is not supported by this distro and because if it isn’t disabled the USB won’t boot.

Give the nomodeset option a try :

I don’t know if i understood correctly what that thread says i should do, but i interpreted that i should press the “e” key during boot selection, and then add the nomodeset parameter.

The problem with that, is that i never get to the part of kernel selection, and when the hyphen starts blinking if i try to press the “caps lock” key for example, it wont respond, also tried ctrl+alt+del and doesn’t reboots the machine, it doesn’t responds.

So i would guess that pressing “e” wont get me anywhere, maybe there’s another way to set that parameter that I’m not aware of.

I must say anyways that I haven’t tried it because that means having to reset all my machine again, which consumes time and from the things I tried to make it boot I’m quite confident that i wont be able to configure the nomodeset in this way.

Hello

I suppose this is a typical installation failure not only for Clear Linux OS.

Now I don’t get the Caching messages but is still stuck with the hyphen blinking.

If the screen you saw is like this,
cursor
your PC is trying to boot OS, but something is wrong or missing around boot process, example boot loader. I recommend to check the process below.

https://docs.01.org/clearlinux/latest/guides/maintenance/fix-broken-install.html

Or do clean install again.

1 Like

espio hi,

That’s what I see, it blinks for like 15 seconds or more and then stops.

I stumbled upon that page and followed those steps, but had the same result.

Even tried the server iso, and if the version was old it won’t even recognize the SSD during install configuration, but newer versions did and the result is the same.

I’m kinda stuck here, maybe the hardware isn’t fully supported yet, the processor is quite new.

I checked this page Compatible Hardware — Documentation for Clear Linux* project but idk it seems outdated

Just tried to install v31779 and this is how far i can get with the usb image

I then pressed alt f2 and tried clr-installer but this version wont pick up the drive.

So I think it isnt a wayland config problem.

try desktop live image

I tried the live image, it boots and does install. But after reboot when reading from disk it gets stuck.