Any way to run Hamachi on Clear?

I’ve been trying to setup Hamachi on Clear and so far I haven’t been successful, even though Haguichi is available through Flatpak; I tried to install it through the .tgz provided on their website, which also provides a .rpm and .deb. Is there a way I can get Hamachi running?

I don’t have a way to fully test but Hamachi is still using init scripts, which most distro’s don’t use anymore.
Take a look at: https://community.logmein.com/t5/LogMeIn-Hamachi-Discussions/Hamachi-does-not-seem-to-be-running/td-p/80958

You can use the tar ball, sudo ./install but you need to manually start the service. Not sure if it is working past that.

E.

UPDATE:

I tried to run the command as sudo ./install.sh, which only had one issue.

Copying files into /opt/logmein-hamachi …
Creating LogMeIn Hamachi symlink …
Creating TunTap …
mknod: /dev/net/tun: El fichero ya existe
Installing LogMeIn Hamachi service …
install: no se puede crear el fichero regular ‘/etc/init.d/logmein-hamachi’: No existe el fichero o el directorio
Cannot install hamachi autostart scripts.
Starting LogMeIn Hamachi service …
./install.sh: línea 66: /etc/init.d/logmein-hamachi: No existe el fichero o el directorio
LogMeIn Hamachi is installed. See README for what to do next.

Apparently /etc/init.d/logmein-hamachi does not exist.

Well, after some poking I finally got it working, I’m going to post it if it helps anybody, after running install.sh, I had to search for a systemd deamon that was available in the AUR, this one, and pasted it into /etc/systemd/system/, and finally ran:

systemctl start logmein-hamachi.service
sudo systemctl enable logmein-hamachi

And afterwards I just installed Haguichi, thanks for the help.

1 Like