Battery indicator status is constantly 'not charging'

My huawei matebook d15 laptop indicator status is always ‘not charging’ despite charge light showing full. After a short while of fresh installation, indicator stops working properly with constant ‘not charging’ status notwithstanding charge cable plugged or not. I tried depleting battery and it is of no use either.

I tried reinstalling clear linux several times but the issue is persistent.

Clear linux is my daily driver on the same laptop 2-3 months and this annoyance appeared just recently.

To check whether this is inherent to my hardware i have tried fedora and opensuse for a few days and the issue is not present with both, so I presume there is no problem with my battery and suspect this issue might be related to the last update of clear os?

Screenshot from 2022-08-23 11-36-31

Does the charge indicator go red after waking up the screen?

Thank you. Actually, it has been red all the time since after few hours of fresh installation. Nevertheless I tried suspending and resuming and it still is red.

Hm… while I don’t know what may be causing the issue, I had a problem on my netbook with hardware acceleration, it broke in Linux kernel 5.19.
Since I did not change any configuration and the issue “magically” appeared, I ended up going to the LTS version of the Linux kernel, which is more stable than the native version.
After doing that, hardware acceleration worked flawlessly again:

Try to change to the LTS kernel, it may help you.

NOTE: Remember to reboot the computer after setting the kernel in terminal.


LTS Kernel solved it! Thanks Dapal.