Can’t boot Clear Linux

I cannot seem to boot Clear Linux. From other topics I found that it could be that my laptop (HP Elitebook 840 G1) is hard coded to boot some Windows 10 boot EFI path. However, I have an option in the BIOS called Customized Boot Option and but it still doesn’t seem to work. I don’t know what to do anymore. And yes, the firmware is updated.

If it has a ‘legacy’ mode (instead of uefi) try that.
CL requires a uefi bios but, weirdly, you don’t have to have uefi switched on!

I have three modes and I’ve tried all of them.

Try installing from the live ISO with the bios in legacy mode.

That‘s what I did. Provided that the stick is in legacy mode. That is, when in pure UEFI mode, the USB doesn’t show up. Maybe I would have had to make the USB in UEFI mode? In Etcher I don’t have any option.

The image created by Etcher should be bootable from bother UEFI and legacy mode.

Problem solved! The problem was Etcher didn’t make my USB available in UEFI. I made it with Rufus, set it to UEFI, and now it boots!