Problems installing ClearLinux

Hi.

I am having problems trying to install Clear Linux on an HP Notebook, I have followed the recommended steps to burn the ISO to a USB drive, and ran the compatibility checkup scripts before attempting the installation, all checks reported success.

The problem is, when I enable secure-boot in the BIOS, I do not get the option to boot from USB (when pressing F9), if I try it with legacy-mode, I get the option to boot from USB, but when proceeding I get the error “isolinux.bin missing or corrupt”.

Before trying this on my HP Notebook, I tested this on a DELL PC and I encountered the same behavior (legacy vs. secure boot), and I was able to fix it by enabling secure-boot then creating a manual boot entry in the bios, pointing to the UEFI file inside the USB drive.

Unfortunately, I have limited options on the HP Notebook when configuring the BIOS, I can only change the boot order, enable or disable secure boot, but it’s not possible to add a manual boot entry.

Any pointers are appreciated.

Thanks.

Do you have to enable secure boot? In my bios there’s a secure boot for Windows and another one for other OS where the first one explicitly says it might not work for other OS.

It seems you do need to enable secure boot, I am certain there is nothing wrong with the media on the USB drive as I have verified the hash of the Clear Linux ISO when I downloaded it, and as I mentioned, I was able to boot from the same USB drive on a DELL PC by creating a manual boot entry.

Were you able to install Clear Linux without secure boot? I followed the steps here to burn the ISO using the dd command:

https://docs.01.org/clearlinux/latest/get-started/bootable-usb.html#bootable-usb-linux

@muhannad, Clear Linux does not support secure boot at this time. You need to make sure that secure boot is disabled and you are booting with UEFI, no legacy BIOS support enabled.

I see, thanks for narrowing down the problem, then I guess I have to work around the “isolinux.bin missing or corrupt” error, as I am still getting the same message with both legacy & secure modes disabled.

I am not sure why it worked on Dell, as I was able to install Clear Linux from the same USB drive and with secure boot enabled.

Try to update the BIOS, that might solve strange problems.

Definitely update your system firmware if there is a newer one available.

You are selecting the USB drive using the boot menu to override the boot order stored in settings. Go into the firmware settings and make sure:

  1. there is no legacy BIOS support enabled
  2. set your USB drive as the first drive in your boot order
  3. save and reboot

Both secure boot & legacy support are disabled.

I tried setting both USB options under UEFI as the first boot choice, saved and rebooted, the USB drive blinks for 1 or 2 seconds and then it boots into the currently installed OS (CentOS).

I don’t know a whole lot about the Insyde BIOS and how old this particular system is. In the setup utility, is there a tab screen for boot? I’m wondering if you can set the emulation type for the USB to CDROM.

Also, did you create the USB using the DD command in linux? Do you have access to a Windows machine and try using rufus to create your USB?

The image on the USB is a GPT image (GUID partition table). Were you able to boot to the USB device on the Dell? Not sure why enabling secure boot would all of a sudden make that work and I would have expected the opposite.

@TOML I followed your advice, used rufus on a Window vm to burn the iso to a new thumb drive, and it worked like charm.

Thanks a million! :smiley:

2 Likes

@muhannad, good to hear!

1 Like