Can not boot Clear Linux after fresh install

I have done a lot of search on similar issue but could not find a working answer.

I have succeeded in installing Clear Linux (34000) on an old HP EliteBook 8560w where UEFI support is experimental but enabled.
But when I boot my laptop, Clear Linux does not start as BIOS complains that “BootDevice Not Found - Please install an operating system on your hard disk”.

Rebooting with the USB key, I mounted the /dev/sda1 partition on /mnt (normally the boot partition) but could not find any efi folder in the boot partition. (Clear Linux was installed with destructive install on /dev/sda)
Is it expected ?

From bios, I also tried to boot from EFI file, but I can’t find any…

Thanks for your help.

Try CSM and/or Legacy mode in the BIOS setup.
Also, which processor does it have?

Thanks for you answer.

What do you mean by try CSM?
I have tried legacy mode, no change, still does not boot.

Processor is a i5 2540M.

If someone can tell me which files are there in /boot folder, it may help me.
On my side I have files:

  • freestanding-00-intel-ucode.cpio
  • freestanding-i915-firmware.cpio.xz
  • ldlinux.c32
  • ldlinux.sys
  • syslinux.cfg
  • org-clearlinux.native.5.9.12-1004

and nothing more.

I finally solved my installation issue.
I created the USB key with dd command. And when I booted on the USB key, the boot was done in legacy mode, not with UEFI. Therefore bootctl was not able to create correctly the /boot folder. And it was not able to boot.
I have redone the installation and this time I took care to boot the USB key in UEFI mode. The installation was correct and it correctly booted.
Hope it can help someone…

1 Like